Bug 63090 - mesa 9.2git: qvdpautest fails to work with UVD but also fails with shader decoding
Summary: mesa 9.2git: qvdpautest fails to work with UVD but also fails with shader dec...
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2013-04-03 22:04 UTC by Arkadiusz Miskiewicz
Modified: 2013-06-09 17:50 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Arkadiusz Miskiewicz 2013-04-03 22:04:28 UTC
Tried to test vdpau using

but it failed with:
qvdpautest 0.5.2
AMD E-350 Processor
Unknown GPU

VDPAU API version : 1
VDPAU implementation : G3DVL VDPAU Driver Shared Library version 1.0

FATAL: get_bits failed : No backend implementation could be loaded.!!

and very bad framerate (MPEG DECODING (1920x1080): 53 frames/s)

"No backend implementation could be loaded" happened with shaders decoding and also with UVD decoding (while mplayer -vo vdpau worked fine on both cases)

"No backend implementation could be loaded" is mesa VDP_STATUS_NO_IMPLEMENTATION

Test environment:
- kernel from drm-fixes + radeon UVD patches (http://lists.freedesktop.org/archives/dri-devel/2013-April/036766.html + http://paste.debian.net/247063/)

- mesa 9.2 from master as of 302df7cc85b0e2ce47c40048f30bd116b0d692fc + patches http://comments.gmane.org/gmane.comp.video.mesa3d.devel/55622 and http://lists.freedesktop.org/archives/mesa-dev/2013-April/037089.html

- E350 AMD APU with [AMD] nee ATI Wrestler [Radeon HD 6310] GPU

- vdpauinfo with shaders: http://pastebin.com/UV2CAX9F
- vdpauinfo with UVD working: http://pastebin.com/FjpLyMqr
Comment 1 ryszardzonk 2013-04-09 13:29:25 UTC
I have same platform as Arkadiusz [E-350] and I can confirm his results of 53 frames/s. 

software used:
Kernel 3.9-rc6 + drm uvd patches
libdrm Git 08.04.2013
xorg-server 1.13.3
Mesa Git 08.04.2013 + uvd patch

On the other hand mplayer -vo vdpau was not enough to get smooth playback of H264 content. I had to specify "mplayer -vo vdpau -vc ffh264vdpau" with perfect results. Using standard combination of "mplayer -vo vdpau -vc ffmpeg12vdpau,ffvc1vdpau,ffh264vdpau,ffodivxvdpau" on the H264 content made mplayer use ffmpeg12vdpau which resulted in jerky playback. 
Using XBMC from FernetMenta tree https://github.com/FernetMenta/xbmc which has number of vdpau playback fixes resulted in jerky playback for high bitrate content at 1920@1080.

As of VC1 content any player I used created either dark screen with green artifacts at playback

Please let me know if You need any logs (dmesg/Xorg/lspci) or configs (kernel/Xorg) or any other for that matter
Comment 2 Christian König 2013-04-09 13:46:39 UTC
That's a bug in qvdpautest. It tries to get the surface data in YUYV format, which is simply not supported by the hardware.

We could implement a software fallback, but mesuring that would be pretty much nonsense.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.