Bug 63701 - [HSW] support new haswell graphics [8086:0a2e]
[HSW] support new haswell graphics [8086:0a2e]
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/Intel
unspecified
x86-64 (AMD64) Linux (All)
: high critical
Assigned To: Paulo Zanoni
Intel GFX Bugs mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-19 01:44 UTC by EvaWang
Modified: 2013-06-25 09:30 UTC (History)
2 users (show)

See Also:


Attachments
dmesg and Xorg.0.log (22.48 KB, application/x-zip)
2013-04-22 08:59 UTC, EvaWang
no flags Details
Add 0ade dmesg and xorg.0.log (23.99 KB, text/plain)
2013-04-24 03:29 UTC, EvaWang
no flags Details
Xorg.0.log (10.15 KB, text/plain)
2013-05-30 10:17 UTC, EvaWang
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description EvaWang 2013-04-19 01:44:17 UTC
It can't enter to OS with latest kernel 3.9.0-rc7 on intel new haswell graphics [8086:0a2e]
Where can we get the driver for this graphics card?
Thanks!!
Comment 1 EvaWang 2013-04-19 02:38:53 UTC
Hardware is Core i5-4258U(5100, GT3)
Comment 2 Ben Widawsky 2013-04-19 06:56:19 UTC
That PCI ID is new to me, and I cannot find details about the actual part so I am hesitant to write a real patch. Paulo have you seen that one? 

Since very limited people have access to HSW hardware at this point, you should be working through Intel or whatever vendor provided the HW to you for the proper fix. Also, as far as I can tell, the Haswell model you specify doesn't exist in any official Intel documentation. For that reason, I would again recommend you through whichever vendor provided the hardware to you (and close this bug)

With all that disclaimer above... If you'd like to fix it yourself, patches are welcome. In drivers/gpu/drm/i915/i915_drv.c, copy one and modify with your PCI ID.

        INTEL_VGA_DEVICE(0x0D02, &intel_haswell_d_info), /* CRW GT1 desktop */
        INTEL_VGA_DEVICE(0x0D12, &intel_haswell_d_info), /* CRW GT2 desktop */
        INTEL_VGA_DEVICE(0x0D22, &intel_haswell_d_info), /* CRW GT2 desktop */
        INTEL_VGA_DEVICE(0x0D0A, &intel_haswell_d_info), /* CRW GT1 server */
        INTEL_VGA_DEVICE(0x0D1A, &intel_haswell_d_info), /* CRW GT2 server */
        INTEL_VGA_DEVICE(0x0D2A, &intel_haswell_d_info), /* CRW GT2 server */
        INTEL_VGA_DEVICE(0x0D06, &intel_haswell_m_info), /* CRW GT1 mobile */
        INTEL_VGA_DEVICE(0x0D16, &intel_haswell_m_info), /* CRW GT2 mobile */
        INTEL_VGA_DEVICE(0x0D26, &intel_haswell_m_info), /* CRW GT2 mobile */


Keep in mind, just about every graphics component which needs PCI ids will have the same problem.
Comment 3 Chris Wilson 2013-04-20 06:32:33 UTC
Let's start with a dmesg and Xorg.0.log to verify the basics.
Comment 4 EvaWang 2013-04-22 08:59:09 UTC
Created attachment 78322 [details]
dmesg and Xorg.0.log
Comment 5 EvaWang 2013-04-22 09:00:26 UTC
 Atachment dnesg_and_Xorg.0.log is dmesg and Xorg.0.log. In legacy mode, i915 doesn't load and system is started by vesa. In UEFI mode, the system can not be started by vesa.
Comment 6 Daniel Vetter 2013-04-22 09:05:11 UTC
One for Paulo to figure out what we should do with this pc id.
Comment 7 EvaWang 2013-04-24 03:29:32 UTC
Created attachment 78407 [details]
Add 0ade dmesg and xorg.0.log
Comment 8 Paulo Zanoni 2013-04-26 17:08:36 UTC
Yeah, I'll obtain information on what's special about these IDs.

When we have patches on the mailing list I'll update the bug report.

Thanks,
Paulo
Comment 9 Chris Wilson 2013-05-22 11:46:11 UTC
All relevant parties have now been updated (I believe)
Comment 10 EvaWang 2013-05-22 12:23:28 UTC
Hi Chris,Could you please tell me how can we get the solution ? Thanks!
Comment 11 Chris Wilson 2013-05-22 12:40:17 UTC
Kernel commit 1c98b4871cca4b7ce07e19f92f934d47cf7210b0
Author: Rodrigo Vivi <rodrigo.vivi@gmail.com>
Date:   Mon May 13 18:12:25 2013 -0300

    drm/i915: Adding more reserved PCI IDs for Haswell.

xf86-video-intel 2.21.7

Looks like mesa/libdrm lack updates.
Comment 12 EvaWang 2013-05-27 06:47:22 UTC
We have updated xf86-video-intel to newest 2.21.7 and mesa to newest 9.1.3, and have added PCI IDs in kernel 3.9.2, but system is still using llvmpipe(software accelebration) to start. 

BTW, we didn't find the patch whose commit number is 1c98b4871cca4b7ce07e19f92f934d47cf7210b0 in kernel.org , could you please provide the kernel link to us?
Comment 13 EvaWang 2013-05-28 14:03:18 UTC
Hi Chris, could you please provide the drm/i915 added this PCI ID to us? Thanks!
Comment 14 Daniel Vetter 2013-05-28 15:59:52 UTC
The drm-intel-fixes branch from http://cgit.freedesktop.org/~danvet/drm-intel/ has them.
Comment 15 EvaWang 2013-05-30 10:17:57 UTC
Created attachment 80028 [details]
Xorg.0.log
Comment 16 EvaWang 2013-05-30 10:23:45 UTC
Hi Daniel, we get source from git://people.freedesktop.org/~danvet/drm-intel(2013-05-28), after compiled it to rpm package and installed to system, Xorg can't start. please refer Xorg.0.log. Thanks!
Comment 17 Chris Wilson 2013-05-30 10:40:40 UTC
missing libdrm; don't use uxa.
Comment 18 EvaWang 2013-06-03 04:01:22 UTC
hi chris, I am sorry I can not totally understand what is the mean of you reply "missing libdrm; don't use uxa". We have try to update libdrm to newest 2.4.45. So do you have any suggestion for us to support this graphics while we have no idea about it? Thanks a lot.
Comment 19 Chris Wilson 2013-06-03 07:47:05 UTC
Your libdrm_intel has not been patched to recognise these Haswell chips and neither has mesa. In the ddx, sna does not depend upon libdrm_intel and will work regardless.
Comment 20 Kenneth Graunke 2013-06-05 22:39:41 UTC
libdrm master, intel-gpu-tools master, and Mesa from either master or the 9.1 branch now recognize these PCI IDs.  I believe that's everything other than libva.
Comment 21 EvaWang 2013-06-10 03:30:11 UTC
Do you mean this PCI ID(8086:0a2e)has been supported by all of related packages, including libdrm,xf86-video-intel,mesa and kernel? If I update all these packages from master, will this graphics become work? Could you tell me the master address?
Comment 22 EvaWang 2013-06-11 13:52:00 UTC
I saw that kernel 3.9.5 has add the solution. but We tried it and solution you mentioned in the last comments, but it still can't support this PCI ID. maybe we misunderstand or lost some patches, could you please help to summary the solution again and it's better to you provide details solution and we will add solution and verify it. I hope we can fix this issue as soon as possible due to OEM's schedule is urgent.We need your support.
Thanks!
Comment 23 EvaWang 2013-06-13 10:02:20 UTC
Hi, Could you please help to summary the solution to us? Thanks!
Comment 24 EvaWang 2013-06-17 12:02:16 UTC
After update libdrm,mesa in master,xorg-x11-drv-intel and kernel in official, this problem has been solved.Thanks a lot for supporting.