Bug 6377 - Bugs in xf86GetOSOffsetFromPCI
Bugs in xf86GetOSOffsetFromPCI
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Server/General
6.9.0
x86 (IA32) Linux (All)
: high normal
Assigned To: Xorg Project Team
:
: 7799 (view as bug list)
Depends on:
Blocks: 2373 5041
  Show dependency treegraph
 
Reported: 2006-03-25 02:59 UTC by Felix Kuehling
Modified: 2006-08-23 00:38 UTC (History)
3 users (show)

See Also:


Attachments
Fix various issues in xf86GetOSOffsetFromPCI (2.01 KB, patch)
2006-03-25 03:03 UTC, Felix Kuehling
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Kuehling 2006-03-25 02:59:13 UTC
We observed initialization failures on Xorg 6.9 and on closer inspection of the
log file it looked like PCI scanning was getting confused and mixing up IO
address ranges with a disabled ROM BAR on a SATA device. I tracked the problems
down to xf86GetOSOffsetFromPCI. I'm about to attach a patch that fixes our
issues. See the comments in the code for details. The patch is against Xorg 6.9,
but I believe it should still apply to CVS HEAD.

ATI Technologies Inc.
Comment 1 Felix Kuehling 2006-03-25 03:03:46 UTC
Created attachment 5044 [details] [review]
Fix various issues in xf86GetOSOffsetFromPCI

This fixes matching of IO BARs with less than 16-byte alignment. It also
ignores disabled BARS. These two problems together lead to problems where the
start and end address of the same IO BAR were matched by different BARS and
translated differently. The change of <= to < fixes a potential problem when
two BARS are immediately adjacent in address space. The base address of one BAR
may have been matched by a BAR immediately preceeding it.
Comment 2 Felix Kuehling 2006-04-04 01:12:01 UTC
Tentatively block Xorg 7.1 release tracker. I'd like my patch reviewed by
someone more competent than me (PCI spec, different platforms, especially Altix
that introduced the problem) before committing it.
Comment 3 Felix Kuehling 2006-05-05 06:25:00 UTC
Ping. Is anyone going to look at this before the Xorg 7.1 release?
Comment 4 ajax at nwnk dot net 2006-05-19 00:35:30 UTC
This looks correct to me, I think.  I'm doing a final round of testing today
with this included, so if it smokechecks I think it's good to include.
Comment 5 Felix Kuehling 2006-05-19 00:40:07 UTC
(In reply to comment #4)
> This looks correct to me, I think.  I'm doing a final round of testing today
> with this included, so if it smokechecks I think it's good to include.

Thank you! I had already given up hope of seeing this in 7.1. :-)
Comment 6 ajax at nwnk dot net 2006-05-19 09:49:25 UTC
works on everything i could test on.  applied, thanks!
Comment 7 Tom Wa 2006-08-16 07:23:56 UTC
*** Bug 7799 has been marked as a duplicate of this bug. ***