Bug 64186 - Don't treat remote users as system accounts
Summary: Don't treat remote users as system accounts
Status: RESOLVED FIXED
Alias: None
Product: accountsservice
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-03 14:33 UTC by Stef Walter
Modified: 2013-05-15 14:40 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Don't erroneously exclude users in wtmp or who have been cached (4.18 KB, patch)
2013-05-14 07:29 UTC, Stef Walter
Details | Splinter Review
Don't treat remote users as system accounts (880 bytes, patch)
2013-05-14 15:30 UTC, Stef Walter
Details | Splinter Review

Description Stef Walter 2013-05-03 14:33:30 UTC
If we have cached login data for a user, we should never 'exclude' their account in the list.

This is especially true since getting the excluded users 'right' has proven to be pretty hard.
Comment 1 Stef Walter 2013-05-14 07:29:19 UTC
Created attachment 79284 [details] [review]
Don't erroneously exclude users in wtmp or who have been cached

Be strict about excluding users that we find in the local passwd file,
but far more lenient about excluding users that have either logged in
at some point, or been explicitly cached via 'CacheUser'

This fixes regressions for users using network authentication via
winbind or sssd.
Comment 2 Stef Walter 2013-05-14 15:30:45 UTC
Created attachment 79308 [details] [review]
Don't treat remote users as system accounts

Fix a bug in the logic that determines whether a user is a system
account or not. Don't treat accounts that have no shadow information
as remote users.
Comment 3 Ray Strode [halfline] 2013-05-14 18:25:40 UTC
feel free to push.
Comment 4 Stef Walter 2013-05-15 14:40:44 UTC
Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.