Bug 64261 - [SNB Bisected]Ogles3conform GL3Tests_color_buffer_float_color_buffer_float_clamp_fixed.test fail
[SNB Bisected]Ogles3conform GL3Tests_color_buffer_float_color_buffer_float_cl...
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
All Linux (All)
: high major
Assigned To: Kenneth Graunke
:
Depends on:
Blocks: 67224
  Show dependency treegraph
 
Reported: 2013-05-06 02:31 UTC by lu hua
Modified: 2013-08-19 02:49 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2013-05-06 02:31:19 UTC
System Environment:
--------------------------
Arch:             i386
Platform:         Sandybridge
Libdrm:		(master)2.4.44-6-g011999927f76a7e9ba8f047fae4b4e084da6c2c3
Mesa:		(master)abbbc9b667d1156a42a4e2bf4eee591f8ab2946f
Xserver:(master)xorg-server-1.14.99.1-37-g451ba4bd41b82acd4aec6236ba121e00cfeb311b
Xf86_video_intel:(master)2.21.6-25-g5637c173f85a5bb9a77572e4c070e0d612e6f49d
Cairo:		(master)32bd6aa46dc77c497f06d2ab3bf0c2ec218d9e19
Libva:		(staging)63182cd2c03019751b8a2ded17082324be143417
Libva_intel_driver:(staging)5bd630d4ea732818728b0a464f45739c86e08be3
Kernel:	(drm-intel-nightly) 040e2924d084ac3605d0e7f799d9ca71fc7b66c0

Bug detailed description:
-------------------------
It fails on sandybridge with mesa master branch.It works well on 9.1 branch.
Following cases also fail with same bisect commit:
GL3Tests_color_buffer_float_color_buffer_float_clamp_off.test
GL3Tests_color_buffer_float_color_buffer_float_clamp_on.test
GL3Tests_packed_pixels_packed_pixels.test
GL3Tests_packed_pixels_packed_pixels_pbo.test
GL3Tests_packed_pixels_packed_pixels_pixelstore.test

Bisect shows:de7e8b1d014aaecf87c2b26e8ab7e89266d5e176 is the first bad commit.
commit de7e8b1d014aaecf87c2b26e8ab7e89266d5e176
Author:     Eric Anholt <eric@anholt.net>
AuthorDate: Thu Apr 25 14:41:36 2013 -0700
Commit:     Eric Anholt <eric@anholt.net>
CommitDate: Mon Apr 29 11:41:34 2013 -0700

    intel: Be more conservative in disabling tiling to save memory.

    Improves GLB2.7 trex performance 1.01985% +/- 0.721366% on my IVB (n=10)
    and by 3.38771% +/- 0.584241% (n=15) on my HSW, due to a 32x32 ARGB8888
    cubemap going from untiled to tiled.

    Reviewed-by: Daniel Vetter <daniel.vetter@ffwll.ch>

Reproduce steps:
----------------
1. xinit
2. ./GTF -width=64 -height=64 \
-run=GL3Tests/color_buffer_float/color_buffer_float_clamp_fixed.test
Comment 1 Gordon Jin 2013-05-24 05:10:46 UTC
Eric, can you reproduce?
Comment 2 Kenneth Graunke 2013-08-14 00:46:50 UTC
Patch on the mailing list:
http://lists.freedesktop.org/archives/mesa-dev/2013-August/043267.html
Comment 3 lu hua 2013-08-14 05:52:39 UTC
(In reply to comment #2)
> Patch on the mailing list:
> http://lists.freedesktop.org/archives/mesa-dev/2013-August/043267.html

Fixed by this patch.
Comment 4 Kenneth Graunke 2013-08-15 22:45:23 UTC
Fixed on master by:

commit c189840b21e176d87cbb382e64e848061b8c7b06
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Tue Aug 13 15:03:12 2013 -0700

    i965: Force X-tiling for 128 bpp formats on Sandybridge.
    
    128 bpp formats are not allowed to be Y-tiled on any architectures
    except Gen7.
    
    +11 Piglits on Sandybridge (mostly regression fixes since the
    switch to Y-tiling).
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=63867
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=64261
    Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
    Reviewed-by: Chad Versace <chad.versace@linux.intel.com>
    Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>
    Cc: "9.2" <mesa-stable@lists.freedesktop.org>
Comment 5 lu hua 2013-08-19 02:49:10 UTC
Verified.Fixed.