Bug 6436 - xorg don't support fujitsu siemens P20-2 high resolution 1600x1200
Summary: xorg don't support fujitsu siemens P20-2 high resolution 1600x1200
Status: RESOLVED DUPLICATE of bug 643
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Alan Hourihane
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-31 00:10 UTC by Pavel Stehule
Modified: 2006-05-08 03:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.log (50.32 KB, text/plain)
2006-03-31 00:12 UTC, Pavel Stehule
no flags Details
log xorg 6.9 (51.68 KB, text/plain)
2006-04-05 22:18 UTC, Pavel Stehule
no flags Details
xorg.conf (2.63 KB, text/plain)
2006-04-10 20:43 UTC, Pavel Stehule
no flags Details
with unmodified xorg.conf (52.85 KB, text/plain)
2006-04-10 20:45 UTC, Pavel Stehule
no flags Details
without ddc (48.57 KB, text/plain)
2006-04-11 00:33 UTC, Pavel Stehule
no flags Details
log with MonitorLayout (49.37 KB, text/plain)
2006-04-13 04:00 UTC, Pavel Stehule
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Stehule 2006-03-31 00:10:10 UTC
Hello

I try set 1600x1200 resolution for this monitor. I have i855 card and Xorg
6.8.1. I tryed lot of modelines, but I didn't find any line which monitor can
accept. For modelines I used internet available modeline calculators. All tests
finish error Out of range. Interesting is, monitor report different values, than
I used for calculation. I generated freq 60Hz and monitor reports from 80-63Hz.
I tested off DDC but without success. I used 855resolution too. This monitor
needs for 1600x1200 exactly 75/60Hz freq, and it's source of problems.

Can You help me. Is there support for this monitor? Or different modelines
calculator for LCD monitors. I am sure I used good values for Modeline calculations.

Thank You
Pavel Stehule
Comment 1 Pavel Stehule 2006-03-31 00:12:02 UTC
Created attachment 5130 [details]
xorg.log
Comment 2 Pavel Stehule 2006-04-05 22:18:45 UTC
Created attachment 5202 [details]
log xorg 6.9

This log don§t show any bug, but monitor show message: Frequency out of range
108Khz/88Hz Please change the display to 1600x1200 with 60Hz
Comment 3 Pavel Stehule 2006-04-05 22:22:30 UTC
I tested xourg 6.9 with new i810 driver from
http://www.fairlite.demon.co.uk/intel.html but without success. I used
-configure generated xorg.conf. Still I can work only in 1280x1200 resolution.
In higher resolution monitor show only message: Frequency out of range
108Khz/88Hz Please change the display to 1600x1200 with 60Hz

Regards
Pavel Stehule
Comment 4 Alan Hourihane 2006-04-10 18:34:57 UTC
You should upload logs from Xorg 6.9.
Comment 5 Alan Hourihane 2006-04-10 18:36:38 UTC
Actually, I can see the log for 6.9 - Sorry.

I think the problem is that you are defining your own modelines which are wrong.

You've defined a modeline that uses 65Hz which is more than your monitor can do.

Just try removing all your modelines, as the Xserver will use it's own
calculated ones anyway.
Comment 6 Pavel Stehule 2006-04-10 20:43:34 UTC
Created attachment 5251 [details]
xorg.conf
Comment 7 Pavel Stehule 2006-04-10 20:45:10 UTC
Created attachment 5252 [details]
with unmodified xorg.conf
Comment 8 Pavel Stehule 2006-04-10 20:45:32 UTC
I tryed use xorg.conf without modelines first, but without success. I am sending
xorg.conf generated via --configure param which I use. I modifyed only mouse
params. And result is wrong, Frequency out of range 107Khz/87Hz
Comment 9 Alan Hourihane 2006-04-10 21:05:09 UTC
Ok. The easiest thing to do here is add

Option "NoDDC"

and make sure VertRefresh is set to just 60.
Comment 10 Pavel Stehule 2006-04-10 21:47:30 UTC
(In reply to comment #9)
> Ok. The easiest thing to do here is add
> 
> Option "NoDDC"
> 
> and make sure VertRefresh is set to just 60.

It's not help me. I set it and monitor reports: Frequency out of range
99Khz/80Hz.  I afraid it's serios bug :-(. Windows works fine.
Comment 11 Alan Hourihane 2006-04-10 22:23:44 UTC
Try going back to the driver that shipped with Xorg 6.9 (and not using my test
driver).
Comment 12 Pavel Stehule 2006-04-10 22:29:19 UTC
(In reply to comment #11)
> Try going back to the driver that shipped with Xorg 6.9 (and not using my test
> driver).

It's same. Can I do some detailed diagnostics?
Comment 13 Alan Hourihane 2006-04-10 22:38:32 UTC
Upload a log with those options and the Xorg 7.0 driver.
Comment 14 Pavel Stehule 2006-04-11 00:33:16 UTC
Created attachment 5255 [details]
without ddc
Comment 15 Alan Hourihane 2006-04-11 00:46:23 UTC
O.k. the log looks fine and if it still isn't working, I suggest you try seeing
if there is an updated Video BIOS for your machine from the manufacturer.

In Linux, we rely on the Video BIOS setting the mode, whereas Windows doesn't.
Comment 16 Pavel Stehule 2006-04-12 01:50:10 UTC
(In reply to comment #15)
> O.k. the log looks fine and if it still isn't working, I suggest you try seeing
> if there is an updated Video BIOS for your machine from the manufacturer.
> 
> In Linux, we rely on the Video BIOS setting the mode, whereas Windows doesn't.

I found only one bios update from july 2005 and applyed them. But this update
hadn't any efect on VIDEO BIOS. My video bios number is 2991. I didn't find any
way how I can update it :-(. Is there any chance for success? I know nothing
about similar bug. 

Comment 17 Alan Hourihane 2006-04-12 22:44:00 UTC
Try adding this to your Device Section....

Option "MonitorLayout" "NONE,CRT+LFP"

Comment 18 Alan Hourihane 2006-04-12 22:46:37 UTC
If that doesn't work, remove the MonitorLayout command and add this ModeLine to
your Monitor Section..

ModeLine "1600x1200" 162 1600 1664 1856 2160 1200 1201 1204 1250
Comment 19 Pavel Stehule 2006-04-13 04:00:47 UTC
Created attachment 5280 [details]
log with MonitorLayout
Comment 20 Pavel Stehule 2006-04-13 04:01:04 UTC
(In reply to comment #18)
> If that doesn't work, remove the MonitorLayout command and add this ModeLine to
> your Monitor Section..
> 
> ModeLine "1600x1200" 162 1600 1664 1856 2160 1200 1201 1204 1250

I tested all, but without success. If I set Monitor Layout, then I get screeen
1024x768. I uploaded log
Comment 21 Alan Hourihane 2006-04-13 04:04:48 UTC
Does 1280x1024 work at 60Hz ??
Comment 22 Pavel Stehule 2006-04-13 04:08:07 UTC
(In reply to comment #21)
> Does 1280x1024 work at 60Hz ??

No 80Khz/75Hz .. it's limit, 60Hz is limit only for 1600x1200
Comment 23 Alan Hourihane 2006-04-13 04:22:47 UTC
That's not the point. Does any resolution work at 60Hz ??
Comment 24 Pavel Stehule 2006-04-13 06:43:24 UTC
(In reply to comment #23)
> That's not the point. Does any resolution work at 60Hz ??

Yes, I tested 640x480 31khz/60Hz or 1280x1024 65kHz/61Hz, I used modeline
#Modeline "1280x1024" 110.29 1280 1368 1496 1688 1024 1025 1028 1089           
 # 110.29 MHz,  65.34 kHz,  60.00 Hz, AR 1.250:1
Comment 25 Alan Hourihane 2006-04-14 18:41:12 UTC
You might want try getting the 'modesetting' branch code from the git repository
and building it yourself which doesn't rely on the VideoBIOS.

If you've any problems doing this, I suggest joining the xorg lists and posting
there for help.
Comment 26 Pavel Stehule 2006-04-14 18:45:34 UTC
(In reply to comment #25)
> You might want try getting the 'modesetting' branch code from the git repository
> and building it yourself which doesn't rely on the VideoBIOS.
> 
> If you've any problems doing this, I suggest joining the xorg lists and posting
> there for help.

ok, I'll try it. Thank You
Pavel
Comment 27 Pavel Stehule 2006-04-19 14:48:33 UTC
(In reply to comment #26)
> (In reply to comment #25)
> > You might want try getting the 'modesetting' branch code from the git repository
> > and building it yourself which doesn't rely on the VideoBIOS.
> > 
> > If you've any problems doing this, I suggest joining the xorg lists and posting
> > there for help.
> 
> ok, I'll try it. Thank You
> Pavel

I tested it. Without success. This driver is very unstable yet and finish with
wrong card's settings. I had to restart computer. When I run it with generated
configuration I got freq 170Khz/136Hz. But this driwer doesn't work on res.
1280x1024 too.
Comment 28 Alan Hourihane 2006-05-08 20:52:35 UTC
Marking as duplicate of 643 because the new modesetting branch should deal with
all vbios resolution issues.

*** This bug has been marked as a duplicate of 643 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.