Bug 6455 - nv driver freezes display
Summary: nv driver freezes display
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nVidia (open) (show other bugs)
Version: 6.9.0
Hardware: x86 (IA32) Linux (All)
: high critical
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
Depends on:
Reported: 2006-04-01 20:20 UTC by Stefan Tittel
Modified: 2007-05-17 14:53 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

xorg.conf (14.78 KB, text/plain)
2006-04-01 20:22 UTC, Stefan Tittel
no flags Details
Xorg.0.log (39.50 KB, text/plain)
2006-04-01 20:23 UTC, Stefan Tittel
no flags Details

Description Stefan Tittel 2006-04-01 20:20:26 UTC
When starting X 6.9.0 with the nv driver the display comes up showing just a 
black background and the (movable) mouse cursor (and not the display manager it 
is supposed to display). When I try to kill the X server pressing 
Control+Alt+Backsapce the mouse cursor vanishes, leaving me just with a black 
screen and I have to reboot the maschine via SSH.

I attach my xorg.conf and Xorg.0.log. As far as I can see there is nothing 
unusual there. I also tried the nv driver with a clean xorg.conf created by 
xorgconfig, the result was just the same.

I'm running kernel 2.6.15 on an AMD64 maschine. Thank in advance for fixing 
Comment 1 Stefan Tittel 2006-04-01 20:22:44 UTC
Created attachment 5152 [details]
Comment 2 Stefan Tittel 2006-04-01 20:23:12 UTC
Created attachment 5153 [details]
Comment 3 R. Steven Rainwater 2006-04-24 01:03:32 UTC
I may be experiencing this problem on 7.0 as well. I am running on a Dell
Inspiron 8600 with an Nvidia GeForce FX Go5200. It worked perfectly running
Fedora Core 3 and Fedora Core 4 which ran older versions of X windows. After a
new install of Fedora Core 5, which runs xorg 7
(xorg-x11-drivers-7.0.2.i386.rpm). I have a problem that seems similar to Stefan's.

I start Linux in mode 5 which boots to the GDM login screen. Getting this far
works reliably 100% of the time. When I type in the name and pass, things get
weird. As the desktop loads X will crash at a random point and I end up back at
the GDM prompt. Maybe one time in 5, everything works and I get a fully working
desktop. After perhaps 4 or 5 X crashes, if I haven't gotten a working desktop,
X will crash (usually to a black screen with a random text character or two in
the upper left corner) and lock up the entire system, forcing me to power off
the computer to restart.

If I switch to init mode 3 and try starting Xorg from a command prompt using
"startx", it fails 100% of the time with exactly the same symptoms as Stefan
reports (black screen with cursor, except I can move the cursor in my case).
Ctrl-Alt-Backspace doesn't work in this case for me either.

There is nothing unusual in the log that I can see except that it includes this
back trace, which looks exactly the same after each crash:

0: /usr/bin/Xorg(xf86SigHandler+0x87) [0x80b86c7]
1: [0xbcf420]
2: /usr/lib/xorg/modules/libfb.so(fbCopyAreammx+0x1ea) [0x4ba44a]
3: /usr/lib/xorg/modules/libfb.so(fbCompositeCopyAreammx+0x66) [0x4ba566]
4: /usr/lib/xorg/modules/libfb.so(fbComposite+0x57b) [0x4ab16b]
5: /usr/lib/xorg/modules/libxaa.so(XAAComposite+0x261) [0x4f8261]
6: /usr/bin/Xorg [0x81543e6]
7: /usr/bin/Xorg(CompositePicture+0xf7) [0x8142007]
8: /usr/bin/Xorg [0x8147d6c]
9: /usr/bin/Xorg [0x81450a5]
10: /usr/bin/Xorg(Dispatch+0x19b) [0x80888eb]
11: /usr/bin/Xorg(main+0x487) [0x80701d7]
12: /lib/libc.so.6(__libc_start_main+0xdc) [0xc027e4]
13: /usr/bin/Xorg(FontFileCompleteXLFD+0xb1) [0x806f511]

Fatal server error:
Caught signal 11.  Server aborting

I can attach my full log and conf if needed.
Comment 4 TMcHardy 2006-10-27 10:57:42 UTC
I am getting a similar issue.

Description of problem:
- Compaq Presario v6030 (V6000 series)
- AMD64 Dual Core Turion
- Fedora Core 6 x86_64
- nVidia based archetecture (Note there will probably be similar problems on
other laptop models in this family with the nVidia archetecture.  The ATI based
will probably not have identical issues)
- nVidia Corporation MCP51 Ethernet Controller

When this card starts up on boot the machine crashes.  Hard lock-up, reset
required.  Situations which this happens:

- During first boot setup screen when selecting "Next" on the Date/Time Screen.
- Just before entering X on startup (Says Starting first time boot then goes to
black screen)
- Leaving X if you manually started the card after boot.
- Randomly if you manually start the card after boot.

This basically renders the network interface on the laptop useless.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Enable "network" on startup for runlevel 5
2. Reboot Machine and allow it to start X.
3. Machine will go to black screen after loading drivers (Starting first boot)

Actual Results:
Machine freezes up.  Only black screen displayed.  Hard reboot required. 

Expected Results:
Machine starts without errors.

Additional info:
I originally thought this was an FC6 issue; however, upon investigation it seems
that this only occurs when going into X.  I can start to runlevel 1 or 3 without
any issues.  The temporary solution was to disable the network card, start up X,
then enable it through the control centre.  However, this is very tedious and I
fear it may cause problems in the future.  I am not overly comfortable with
things like "recompiling the source" so I hope a fix for this can be out soon.
Comment 5 Daniel Stone 2007-02-27 01:31:20 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 6 Stefan Tittel 2007-02-27 01:49:12 UTC
This bug is still present on my system with X 7.1 under Linux regardless of the distribution and X 6.9 under FreeBSD (architecture is always x86_64). Actually it is keeping me from using FreeBSD, because there is no proprietary NVidia driver for FreeBSD/x86_64 and the nv driver is not working (and vesa is hardly an alternative).
Comment 7 Aaron Plattner 2007-03-29 22:39:32 UTC
It sounds like you may be hitting two bugs: A GPU hang and a crash in the evdev module.  They could be related, caused by some module overrunning a buffer.  Do you still see problems if you don't use the evdev driver?  If you still see a hang, try using the NoAccel or NoXaa* options.
Comment 8 Aaron Plattner 2007-05-17 14:03:41 UTC
Over a month with no response.  Closing.
Comment 9 R. Steven Rainwater 2007-05-17 14:20:06 UTC
I'm still seeing this problem with FC5 on my Dell Inspiron 8600 laptop with the latest FC5 updates.  I'll post an update once Fedora 7 is out, though I understand Fedora 7 may be using the new and improved nouveau driver, so maybe that will help.
Comment 10 Aaron Plattner 2007-05-17 14:53:42 UTC
I don't think you're problem is the same as Stefan's.  I would suggest filing a new bug.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.