Bug 65422 - Rename api_validate.[ch] to draw_validate.[ch]
Summary: Rename api_validate.[ch] to draw_validate.[ch]
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: Other All
: medium trivial
Assignee: mesa-dev
QA Contact:
Depends on:
Reported: 2013-06-05 15:28 UTC by Brian Paul
Modified: 2018-04-23 23:24 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Brian Paul 2013-06-05 15:28:01 UTC
Another simple clean-up task:

The api_validate.c file should probably be renamed as draw_validate.c since all the code in the file is related to validating (error checking) GL drawing commands.

Also update the Makefile/SCons files with the new names.
Comment 1 Arnas Milaševičius 2013-06-05 16:34:28 UTC
I'll take this task.
Comment 2 Timothy Arceri 2018-04-23 23:24:32 UTC
Fixed by:

commit 295f57e09a8b67da07dd96609591dc5144031a62
Author: Timothy Arceri <tarceri@itsqueeze.com>
Date:   Mon Apr 23 13:46:15 2018 +1000

    mesa: rename api_validate.{c,h} -> draw_validate.{c,h}
    Reviewed-by: Mathias Fröhlich <mathias.froehlich@web.de>
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=65422

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.