Bug 6639 - xcb-demo/tests/flames crashes on SPARC Solaris
Summary: xcb-demo/tests/flames crashes on SPARC Solaris
Status: RESOLVED WORKSFORME
Alias: None
Product: XCB
Classification: Unclassified
Component: Demos (show other bugs)
Version: unspecified
Hardware: SPARC Solaris
: low minor
Assignee: xcb mailing list dummy
QA Contact: xcb mailing list dummy
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-18 13:11 UTC by Bart Massey
Modified: 2019-02-16 12:51 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bart Massey 2006-04-18 13:11:49 UTC
Compiling and running xcb-demo/tests/flames on a SPARC Solaris box (via SSH
proxy, although that doesn't seem to matter) causes it to dump core.  Inspection
with the debugger made it look like it was mis-computing an array index,
although the cause was not obvious.  There were some signs that perhaps it was
an endianness problem?
Comment 1 Vincent Torri 2006-04-19 01:58:53 UTC
i have indeed not managed at all the endianness. So, there might be problems
with you sparc station. I'll try to look at it.
nevertheless, don't hesitate to put some log from gdb.
Comment 2 Ian Osgood 2006-04-19 06:06:20 UTC
Strange, all the demos (except lissajoux 1) work fine for me on a PPC Mac, so I doubt XCB endianness is 
the issue.
Comment 3 Jamey Sharp 2009-10-09 10:32:50 UTC
Can you still reproduce this bug, Bart?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.