Bug 66501 - Feature request: support multiseat for a single multi-headed graphics card
Summary: Feature request: support multiseat for a single multi-headed graphics card
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: All All
: medium enhancement
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-02 11:34 UTC by Laércio de Sousa
Modified: 2019-10-14 13:20 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laércio de Sousa 2013-07-02 11:34:13 UTC
As long as more display managers gain support to logind's automatic multiseat feature, it would be nice if the couple "Wayland + multiseat capable display manager" also support multiseat for a single multi-headed graphics card.

Currently in X.Org, the only way to do such a thing is launching a bare (no greeter) X server spanning all available monitors, on top of which one launches nested X servers (usually Xephyr windows), one for each seat.

I wonder if Wayland could support this feature without the need of nested servers.

NOTE: I'm not sure if it should be related to Wayland or Weston.
Comment 1 Klaus Kusche 2014-06-01 10:42:08 UTC
Another vote for this one.

Status?
Comment 3 Damian 2014-08-25 15:42:15 UTC
and plus me too :)
Comment 4 Damian 2014-08-25 15:43:34 UTC
why is this set to wayland? should't it be a different component, maybe even correct maintainer doesn't know...
Comment 5 Pekka Paalanen 2014-08-26 07:42:19 UTC
AFAIU, if you do not want a system compositor spanning everything input and output, and then have session compositors for each seat, we would need the DRM KMS device split in the kernel.

What that means is, that the DRM infrastructure would expose several KMS nodes for a single piece of hardware. How the hardware resources (CRTCs, connectors) are split among the KMS nodes is configured by user space during boot. Then each seat would have its own DRM KMS device node (systemd-logind could open those for the compositors, doesn't matter) that is restricted to the monitors intended for that seat.

After that, the modifications necessary to compositors would be minimal.

I think Dave Airlie would know more about that device node splitting, IIRC it was being planned some time in the past, but I have no idea what the idea is nowadays or if anyone is working on it. You might be better asking on dri-devel mailing list.

The KMS nodes would be somewhat alike render nodes, except instead of exposing just GPU computing resources, each node would have a dedicated set of display hardware resources.

In any case, this has nothing to with Wayland, and only a little to do with compositors.
Comment 6 Cristian Ciupitu 2015-11-28 06:11:55 UTC
Any news on this?
Comment 7 Francesco Frassinelli 2016-01-03 16:57:16 UTC
(In reply to Laércio de Sousa from comment #0)
> As long as more display managers gain support to logind's automatic
> multiseat feature, it would be nice if the couple "Wayland + multiseat
> capable display manager" also support multiseat for a single multi-headed
> graphics card.

First of all, thank you for your work on Xephyr.

I would really like to see this feature and maybe it could be possible to crowdfund the development like Timothy Arceri did with KHR_debug support for Mesa and GL_ARB_arrays_of_arrays extension.

Some interesting references:

David Herrmann, for Linux Plumbers Conference (2013)
 - https://dvdhrm.wordpress.com/2013/09/01/splitting-drm-and-kms-device-nodes/

Laércio de Sousa on Xephyr limitations:
 - http://www.phoronix.com/forums/forum/linux-graphics-x-org-drivers/x-org-drm/49351-single-gpu-multi-seat-support-with-x-org-under-xephyr?p=629742#post629742
 - http://lists.x.org/archives/xorg-devel/2015-December/048282.html
Comment 8 Martin Peres 2019-10-14 13:20:05 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.