Bug 6681 - DDC of External monitor should not constrain available resolution of laptop LCD screen
Summary: DDC of External monitor should not constrain available resolution of laptop L...
Status: RESOLVED DUPLICATE of bug 643
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Alan Hourihane
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-21 05:48 UTC by pv+xorg
Modified: 2006-05-08 03:54 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pv+xorg 2006-04-21 05:48:48 UTC
FC5/Thinkpad R52: will (using 915resolution hack) use native 1400x1050.  
However if Xorg 7.0 is started while external 1024x768 LCD panel is connected, 
the DDC probed frequency ranges on the external monitor causes the 1400x1050 
frequency (for the internal panel) to be rejected. 
 
A plea: 
(1) Xorg ideally would keep various displays and their requirements separate. 
(2) a more informative error message in the meantime. "Unplug all other 
monitors if..."
Comment 1 Alan Hourihane 2006-05-08 20:54:41 UTC
The new modesetting branch is removing the BIOS resolution restrictions. You
should try that out.

*** This bug has been marked as a duplicate of 643 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.