Bug 66897 - [865] EGL does not work on Intel 865G
Summary: [865] EGL does not work on Intel 865G
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915 (show other bugs)
Version: 18.3
Hardware: Other Linux (All)
: highest blocker
Assignee: Ian Romanick
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 89689
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-14 13:31 UTC by Armin K
Modified: 2019-09-18 19:37 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Armin K 2013-07-14 13:31:11 UTC
On my Intel 865G card, EGL can't initialize, although DRI2 works with Xorg Server. Here is output from Weston, the Wayland compositor which uses EGL under X11:

Date: 2013-07-14 CEST
[15:27:45.267] weston 1.1.91
               http://wayland.freedesktop.org/
               Bug reports to: https://bugs.freedesktop.org/enter_bug.cgi?product=Wayland&component=weston&version=1.1.91
               Build: 1.1.91-dirty Bump versionto 1.1.91 (2013-07-09 19:51:54 -0400)
[15:27:45.267] OS: Linux, 3.10.0-1-ARCH, #1 SMP PREEMPT Mon Jul 1 21:16:57 CEST 2013, i686
[15:27:45.267] Loading module '/home/armin/wayland/lib/weston/x11-backend.so'
[15:27:45.335] initializing x11 backend
libEGL debug: Native platform type: x11 (autodetected)
libEGL debug: EGL search path is /usr/lib/egl
libEGL debug: added /usr/lib/egl/egl_gallium.so to module array
libEGL debug: added egl_dri2 to module array
libEGL debug: added egl_glx to module array
libEGL debug: dlopen(/usr/lib/egl/egl_gallium.so)
libEGL info: use X11 for display 0x8072e90
libEGL warning: failed to create a pipe screen for i915
libEGL debug: failed to create DRM screen
libEGL debug: EGL user error 0x3001 (EGL_NOT_INITIALIZED) in eglInitialize(failed to initialize screen)

libEGL debug: DRI2: dlopen(/usr/lib/xorg/modules/dri/i915_dri.so)
libEGL debug: DRI2: found extension `DRI_Core'
libEGL info: DRI2: found extension DRI_Core version 1
libEGL debug: DRI2: found extension `DRI_DRI2'
libEGL info: DRI2: found extension DRI_DRI2 version 3
libGL: Can't open configuration file /home/armin/.drirc: No such file or directory.
libEGL debug: DRI2: found extension `DRI_TexBuffer'
libEGL info: DRI2: found extension DRI_TexBuffer version 2
libEGL debug: DRI2: found extension `DRI2_Flush'
libEGL info: DRI2: found extension DRI2_Flush version 3
libEGL debug: DRI2: found extension `DRI_IMAGE'
libEGL info: DRI2: found extension DRI_IMAGE version 5
libEGL debug: DRI2: found extension `DRI_CONFIG_QUERY'
libEGL debug: the best driver is DRI2
libEGL debug: the value (0x9) of attribute 0x3040 did not meet the criteria (0x4)
libEGL debug: the value (0x9) of attribute 0x3040 did not meet the criteria (0x4)
libEGL debug: the value (0x9) of attribute 0x3040 did not meet the criteria (0x4)
libEGL debug: the value (0x9) of attribute 0x3040 did not meet the criteria (0x4)
libEGL debug: the value (0x9) of attribute 0x3040 did not meet the criteria (0x4)
libEGL debug: the value (0x9) of attribute 0x3040 did not meet the criteria (0x4)
[15:28:03.130] failed to choose EGL config
[15:28:03.130] EGL error state: EGL_SUCCESS (0x3000)
[15:28:03.131] fatal: failed to create compositor
Comment 1 Götz 2013-09-05 20:58:19 UTC
I can confirm the same problem with Intel 865G, Weston 1.2.2, Mesa 9.2.0, xf86-video-intel 2.21.15, linux 3.10.10.

$ weston-launch 
Date: 2013-09-05 ECT
[15:49:00.199] weston 1.2.2
               http://wayland.freedesktop.org/
               Bug reports to: https://bugs.freedesktop.org/enter_bug.cgi?product=Wayland&component=weston&version=1.2.2
               Build:  
[15:49:00.199] OS: Linux, 3.10.10-1-ARCH, #1 SMP PREEMPT Fri Aug 30 12:11:59 CEST 2013, i686
config file "weston.ini" not found.
[15:49:00.199] Loading module '/usr/lib/weston/drm-backend.so'
[15:49:00.215] initializing drm backend
[15:49:00.557] using /dev/dri/card0
[15:49:01.088] failed to choose EGL config
[15:49:01.089] EGL error state: EGL_SUCCESS (0x3000)
[15:49:01.089] failed to initialize egl
[15:49:01.095] fatal: failed to create compositor
Comment 2 Tomasz Paweł Gajc 2015-03-28 23:08:12 UTC
Still exists with mesa 10.5.1 on Lenovo t440 laptop.
Same output as in above comment.

I've googled a bit about this and found possible culprit is this commit

http://cgit.freedesktop.org/mesa/mesa/commit/?h=10.5&id=8357abf4c3a7ea7f2c4e2dcc4381333a979a0758
Comment 3 Tomasz Paweł Gajc 2015-03-28 23:12:57 UTC
Looks like fix is here #89689
Comment 4 rtentser 2019-03-06 08:22:14 UTC
Still exist in 18.3.4:

Date: 2019-03-06 +07
[15:13:46.845] weston 5.0.0
               https://wayland.freedesktop.org
               Bug reports to: https://gitlab.freedesktop.org/wayland/weston/issues/
               Build: unknown (not built from git or tarball)
[15:13:46.845] Command line: /usr/bin/weston
[15:13:46.845] OS: Linux, 4.19.0-2-686-pae, #1 SMP Debian 4.19.16-1 (2019-01-17), i686
[15:13:46.846] Starting with no config file.
[15:13:46.856] Output repaint window is 7 ms maximum.
[15:13:46.904] Loading module '/usr/lib/i386-linux-gnu/libweston-5/drm-backend.so'
[15:13:46.928] initializing drm backend
[15:13:46.931] using /dev/dri/card0
[15:13:46.931] DRM: supports universal planes
[15:13:46.931] DRM: does not support atomic modesetting
[15:13:46.931] DRM: supports picture aspect ratio
[15:13:46.947] Loading module '/usr/lib/i386-linux-gnu/libweston-5/gl-renderer.so'
[15:13:47.132] EGL client extensions: EGL_EXT_device_base
               EGL_EXT_device_enumeration EGL_EXT_device_query
               EGL_EXT_platform_base EGL_KHR_client_get_all_proc_addresses
               EGL_EXT_client_extensions EGL_KHR_debug
               EGL_EXT_platform_wayland EGL_EXT_platform_x11
               EGL_MESA_platform_gbm EGL_MESA_platform_surfaceless
[15:13:47.135] No EGL configs with appropriate attributes.
[15:13:47.135] failed to choose EGL config
[15:13:47.144] failed to initialize egl
[15:13:47.149] fatal: failed to create compositor backend
Comment 5 GitLab Migration User 2019-09-18 19:37:38 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/729.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.