Bug 6705 - radeon driver doesn't switch video out in xorg 7.x
Summary: radeon driver doesn't switch video out in xorg 7.x
Status: RESOLVED DUPLICATE of bug 2000
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.0 (2005.12)
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-23 15:06 UTC by Alexey Parshin
Modified: 2007-08-31 07:33 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (14.84 KB, text/plain)
2006-04-23 18:37 UTC, Alexey Parshin
no flags Details
log file (54.52 KB, text/plain)
2006-04-23 18:39 UTC, Alexey Parshin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Parshin 2006-04-23 15:06:01 UTC
Thinkpad can't switch video out between internal screen of the laptop and VGA
output. It was working fine in xorg 6.8.x and stopped working in xorg 7.x.
In both cases, the xorg own radeon driver is used. Normally, the thinkpad ACPI 
module allows to switch between laptop LCS and VGA out.
Comment 1 Erik Andren 2006-04-23 18:27:40 UTC
Please post your xorg.conf and your xorg.log
Comment 2 Alexey Parshin 2006-04-23 18:37:41 UTC
Created attachment 5428 [details]
xorg.conf
Comment 3 Alexey Parshin 2006-04-23 18:39:02 UTC
Created attachment 5429 [details]
log file
Comment 4 Daniel Stone 2006-04-23 19:36:44 UTC
Try Option "BIOSHotkeys".
Comment 5 Alexey Parshin 2006-04-23 19:47:19 UTC
(In reply to comment #4)
> Try Option "BIOSHotkeys".
I already have Option "BIOSHotkeys" "on" (see my xorg.conf). Am I using it in 
the wrong place?
Comment 6 Erik Andren 2006-04-24 04:46:21 UTC
It's correctly placed. I suppose turning it off doesn't make a difference?
Comment 7 Alexey Parshin 2006-04-24 08:36:05 UTC
(In reply to comment #6)
> It's correctly placed. I suppose turning it off doesn't make a difference?

That's correct :(
Comment 8 Alex Deucher 2006-04-27 03:17:30 UTC
Does switching work on the console?  Make sure the thinkpad apci module is
configured correctly (you might also test without it loaded).  It can be
configured to generate acpi events for things like the video toggle button
rather than letting the bios handle it.
Comment 9 Alexey Parshin 2006-05-09 09:55:28 UTC
(In reply to comment #8)
> Does switching work on the console?  Make sure the thinkpad apci module is
> configured correctly (you might also test without it loaded).  It can be
> configured to generate acpi events for things like the video toggle button
> rather than letting the bios handle it.

I have checked the ACPI log. When I press switch monitor button - it doesn't
generate any events. Sleep, lid, power buttons work fine - events are generated
and processed.

I've also tried to use "ati" driver instead of "radeon" (in xorg.conf).
Comment 10 Matthew Saltzman 2006-06-21 14:46:32 UTC
I'm seeing an issue like this, but I'm not sure if it's the same one.

Plugging a projector in video-out results in no image on the external projector.
 "radeontool dac on" has no effect.

Restarting the X server (logging out or <ctrl><alt><bksp>) results in a display,
but the resolution is borked (low-res and stretched vertically).

In that mode xrandr reports:

# xrandr
 SZ:    Pixels          Physical       Refresh
*0    848 x 480    ( 287mm x 163mm )  *-25880
Current rotation - normal
Current reflection - none
Rotations possible - normal
Reflections possible - none

xrandr cannot change resolutions in that mode.

Am I seeing the same bug, or should I open a different one?

BTW, This is a Thinkpad T41.  I use the radeonfb driver in the kernel.  I need
it to make suspend power down the graphics card.  I don't have BIOShotkeys
enabled.  It used to work for me too.
Comment 11 Alex Deucher 2006-06-21 16:59:58 UTC
(In reply to comment #10)
> I'm seeing an issue like this, but I'm not sure if it's the same one.
> 
> Plugging a projector in video-out results in no image on the external projector.
>  "radeontool dac on" has no effect.
> 
> Restarting the X server (logging out or <ctrl><alt><bksp>) results in a display,
> but the resolution is borked (low-res and stretched vertically).
> 
> In that mode xrandr reports:
> 
> # xrandr
>  SZ:    Pixels          Physical       Refresh
> *0    848 x 480    ( 287mm x 163mm )  *-25880
> Current rotation - normal
> Current reflection - none
> Rotations possible - normal
> Reflections possible - none
> 
> xrandr cannot change resolutions in that mode.
> 
> Am I seeing the same bug, or should I open a different one?
> 
> BTW, This is a Thinkpad T41.  I use the radeonfb driver in the kernel.  I need
> it to make suspend power down the graphics card.  I don't have BIOShotkeys
> enabled.  It used to work for me too.

You problem looks like bug 7243.
Comment 12 Matthew Saltzman 2006-06-21 17:29:27 UTC
(In reply to comment #11)
> You problem looks like bug 7243.

Thanks.  On further investigation, I think it looks like 7203.

Comment 13 Marius Andreiana 2007-02-09 01:07:22 UTC
Looks like bug #2000 too. Reporter, please mark this one as dupe.
Comment 14 Alex Deucher 2007-08-31 07:33:06 UTC

*** This bug has been marked as a duplicate of bug 2000 ***


bug/show.html.tmpl processed on Mar 27, 2017 at 10:36:36.
(provided by the Example extension).