Bug 67255 - [NVC3] black screen after resuming from Hibernate
Summary: [NVC3] black screen after resuming from Hibernate
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: 7.7 (2012.06)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 51411 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-24 12:52 UTC by Mike
Modified: 2019-12-04 08:34 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg output (663.39 KB, text/plain)
2013-07-24 12:52 UTC, Mike
no flags Details
dmesg after resuming from hibernation with nouveu.debug=trace (2.01 MB, text/plain)
2013-10-09 10:41 UTC, Mike
no flags Details
dmesg after resuming from suspention with nouveu.debug=trace (907.12 KB, text/plain)
2013-10-09 10:42 UTC, Mike
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike 2013-07-24 12:52:23 UTC
Created attachment 82934 [details]
dmesg output

black screen after resuming from Hibernate

running Debian

kernel 3.10.1 

mesa 9.1.4

xserver 1.12.4

libdrm 2.4.45
Comment 1 Emil Velikov 2013-07-24 13:11:48 UTC
Hi Mike

Have this ever worked before with an older version of the kernel?
Additionally can you try the nouveau git [1]

Cheers
Emil

[1] http://cgit.freedesktop.org/nouveau/linux-2.6/
Comment 2 Mike 2013-07-24 14:01:51 UTC
Hi Emil,

On Wed, 2013-07-24 at 13:11 +0000, bugzilla-daemon@freedesktop.org
wrote:
> Comment # 1 on bug 67255 from Emil Velikov 
> Hi Mike
> 
> Have this ever worked before with an older version of the kernel?
> Additionally can you try the nouveau git [1]

Never worked (I tried 3.2, 3.4, 3.8 and 3.9).

Il' try to compile it tonight and report back.

Cheers

Mike
Comment 3 Ilia Mirkin 2013-07-24 19:15:14 UTC
Looks like the interesting bits are below:

[   65.690862] nouveau 0000:01:00.0: power state changed by ACPI to D0
[   65.810949] nouveau  [     DRM] re-enabling device...
[   65.810980] nouveau  [     DRM] resuming kernel object tree...
[   65.810987] nouveau  [   VBIOS][0000:01:00.0] running init tables
[   67.958077] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000000 FAULT at 0x1127b8 [ IBUS ]
[   67.958810] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000000 FAULT at 0x6101ac [ IBUS ]
[   67.959551] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000000 FAULT at 0x6101e4 [ IBUS ]
[   67.960334] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00100010 FAULT at 0x610028 [ IBUS ]
[   67.960651] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00002000 FAULT at 0x610260 [ IBUS ]
[   67.960991] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x610260 [ IBUS ]
[   67.961331] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x610260 [ IBUS ]
[   67.961615] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x610260 [ IBUS ]
[   67.961957] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x610260 [ IBUS ]

The MMIO read errors continue for a LONG time (I guess there's a nv_wait in there), and then

[   69.960067] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x610260 [ IBUS ]
[   69.960407] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x610260 [ IBUS ]
[   69.960747] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x610260 [ IBUS ]
[   69.960811] nouveau E[   PDISP][0000:01:00.0][0xc000857b][ffff880429852c40] timeout1: 0x00000000
[   69.960813] nouveau E[   PDISP][0000:01:00.0][0xc000857b][ffff880429852c40] init failed, -16
[   69.960823] nouveau E[     DRM] 0xdddddddd:0xd1500000 init failed with -16
[   69.961158] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x610240 [ IBUS ]
[   69.961227] nouveau E[     DRM] 0xffffffff:0xdddddddd init failed with -16
[   69.961406] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000000 FAULT at 0x610028 [ IBUS ]
[   69.961551] nouveau E[     DRM] 0xffffffff:0xffffffff init failed with -16
[   69.961561] nouveau  [     DRM] resuming client object trees...
[   69.961570] nouveau  [   VBIOS][0000:01:00.0] running init tables
[   72.042600] nouveau  [     DRM] resuming display...
[   72.050380] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x6013c0 [ IBUS ]
[   72.050690] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000020 FAULT at 0x641000 [ IBUS ]
[   72.051066] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000008 FAULT at 0x640000 [ IBUS ]
[   72.051815] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000018 FAULT at 0x640000 [ IBUS ]
[   72.052225] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x61c004 [ IBUS ]
[   72.052933] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x640000 [ IBUS ]
[   74.053220] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x641000 [ IBUS ]
[   74.053392] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x642000 [ IBUS ]
[   74.053637] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x640000 [ IBUS ]
[   74.053805] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000010 FAULT at 0x640000 [ IBUS ]
[   74.053973] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000008 FAULT at 0x640000 [ IBUS ]
[   74.054141] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000000 FAULT at 0x61cda4 [ IBUS ]
[   74.054309] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000000 FAULT at 0x61cd20 [ IBUS ]
[   74.054477] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000000 FAULT at 0x61cd00 [ IBUS ]
[   74.054585] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000020 FAULT at 0x642000 [ IBUS ]
[   74.054704] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x640000 [ IBUS ]
[   74.054872] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000018 FAULT at 0x640000 [ IBUS ]
[   74.055041] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000010 FAULT at 0x640000 [ IBUS ]
[   74.055213] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x0000003c FAULT at 0x640000 [ IBUS ]
[   74.055382] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000008 FAULT at 0x640000 [ IBUS ]
[   74.055551] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x0000001c FAULT at 0x640000 [ IBUS ]
[   74.055726] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000008 FAULT at 0x640000 [ IBUS ]
[   74.055897] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000028 FAULT at 0x640000 [ IBUS ]
[   74.056005] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x61c804 [ IBUS ]
[   74.056176] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x80000001 FAULT at 0x61c804 [ IBUS ]
[   74.056285] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x61c830 [ IBUS ]
[   74.056393] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x640000 [ IBUS ]
[   74.056561] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000008 FAULT at 0x640000 [ IBUS ]
[   74.056738] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x0000001c FAULT at 0x640000 [ IBUS ]
[   74.056906] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000010 FAULT at 0x640000 [ IBUS ]
[   74.057075] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000008 FAULT at 0x640000 [ IBUS ]
[   74.057183] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000014 FAULT at 0x640000 [ IBUS ]
[   76.057471] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x642000 [ IBUS ]
[   76.059212] PM: restore of devices complete after 10247.631 msecs
[   77.339814] PM: Image restored successfully.
[   77.339816] Restarting tasks ... done.
[   77.341184] PM: Basic memory bitmaps freed
[   77.341196] video LNXVIDEO:01: Restoring backlight state
[   77.344360] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x6013c8 [ IBUS ]
[   77.349009] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x641000 [ IBUS ]
[   79.349470] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x640000 [ IBUS ]
[   81.349750] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x641000 [ IBUS ]
[   81.350026] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x642000 [ IBUS ]
[   83.350518] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x640000 [ IBUS ]
[   85.350820] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x642000 [ IBUS ]
[   85.385788] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x61a804 [ IBUS ]
[   85.385899] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x61a804 [ IBUS ]
[   85.386009] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00100154 FAULT at 0x61a80c [ IBUS ]
[   85.395493] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x80000000 FAULT at 0x61a80c [ IBUS ]
[   85.395661] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000000 FAULT at 0x61a80c [ IBUS ]
[   85.395770] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x80550000 FAULT at 0x61a804 [ IBUS ]
[   85.395879] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x61a804 [ IBUS ]
[   85.397125] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x61a804 [ IBUS ]
[   85.397238] nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x61a804 [ IBUS ]
[   85.397352] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00100154 FAULT at 0x61a80c [ IBUS ]
[   85.406839] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x80000000 FAULT at 0x61a80c [ IBUS ]
[   85.407007] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000000 FAULT at 0x61a80c [ IBUS ]
[   85.407178] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x80550000 FAULT at 0x61a804 [ IBUS ]
[   88.725230] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x03060030 FAULT at 0x647084 [ IBUS ]

So for some reason the card is just completely screwed on resume. Emil's suggestion of trying nouveau/master is a good one, there have been a bunch of register update changes between 3.10 and 3.11, perhaps they magically make this work again.
Comment 4 Mike 2013-07-29 08:21:57 UTC
Hi,

I compiled the kernel from nouveau git but the same problem persist.

Cheers

Mike

On Wed, 2013-07-24 at 13:11 +0000, bugzilla-daemon@freedesktop.org
wrote:
> Comment # 1 on bug 67255 from Emil Velikov 
> Hi Mike
> 
> Have this ever worked before with an older version of the kernel?
> Additionally can you try the nouveau git [1]
> 
> Cheers
> Emil
> 
> [1] http://cgit.freedesktop.org/nouveau/linux-2.6/
> 
> ______________________________________________________________________
> You are receiving this mail because: 
>       * You reported the bug.
Comment 5 Ilia Mirkin 2013-08-31 01:39:48 UTC
*** Bug 51411 has been marked as a duplicate of this bug. ***
Comment 6 Diether Knof 2013-09-03 19:13:20 UTC
Hello,

I am having the same problem.
System: gentoo
kernel: 3.10.7-gentoo, 3.8.13-gentoo, 3.11 (from kernel.org)

The problem arises without X, I have called '/usr/sbin/hibernate -v3' directly after startup (no X is started automatically).
In /var/log/messages there are more then 400 lines as 
  Sep  3 20:20:39 localhost kernel: nouveau E[    PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x610260 [ IBUS ]
(even the same timestamp).

Greetings
Diether
Comment 7 Mike 2013-10-09 10:41:28 UTC
Created attachment 87327 [details]
dmesg after resuming from hibernation with nouveu.debug=trace
Comment 8 Mike 2013-10-09 10:42:13 UTC
Created attachment 87328 [details]
dmesg after resuming from suspention with nouveu.debug=trace
Comment 9 Mike 2013-10-09 10:44:22 UTC
I have tried with 3.12-rc4 and the problem persists. I have attached dmesg after resuming from suspention (which works) and resuming from hibernation (wich does not work) with nouveau.debug=trace.
Comment 10 Martin Peres 2019-12-04 08:34:31 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-nouveau/issues/47.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.