Bug 6737 - Unclear creative-commons release process
Unclear creative-commons release process
Status: CLOSED DUPLICATE of bug 5619
Product: openclipart.org
Classification: Unclassified
Component: website
unspecified
x86 (IA32) Linux (All)
: high normal
Assigned To: default user for a product
: licence
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-25 15:12 UTC by Jeff Smith
Modified: 2006-09-06 18:22 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Smith 2006-04-25 15:12:05 UTC
I've been trying to upload cliparts that I've created. I select the "release
into the public domain" checkbox as part of my upload, but the entries are
showing up as 0-byte files. Your submission screen tells me that this means I
haven't assigned the public domain rights properly.

I've clicked on the "more information" link about cc licences. It shows me a
screen describing the public domain rights, but when I click on the "proceed"
link on that page, it just reloads the same page. Over and over.

I've got about a hundred images I've created that I'd like to upload. But if I
have to do backflips to grant public rights, I'm not going to spend very much
time on it. Every page I read about how to assign rights points at some other
page for a detailed explanation. I can't find a simple, step-by-step process
described anywhere.

Am I supposed to create some metadata and attach it to the files I upload? Why
on earth should I have to do that? Why can't I click a simple "yes, go ahead and
attach public release metadata for me" button and have your upload procedure do
it for me automatically?

I love the idea of openclipart, but if my experiences are at all typical, it
strikes me that this licencing hurdle might be getting in the way of real
widespread contribution.
Comment 1 Nicu Buculei 2006-04-25 15:56:42 UTC
The zero-byte size problem is a very known bad bug -
https://bugs.freedesktop.org/show_bug.cgi?id=5619
It is one of the reasons we are (slowly) migrating to a new website
infrastructure using cchost.

Jeff Smith wrote:
> Am I supposed to create some metadata and attach it to the files I upload? 
> Why on earth should I have to do that? Why can't I click a simple "yes, go 
> ahead and attach public release metadata for me" button and have your upload
> procedure do it for me automatically?

Some metadata have to be entered manually, like your name and the keywords, but
the license shold work with selecting just a checkbox

> I've got about a hundred images I've created that I'd like to upload. But if 
> I have to do backflips to grant public rights, I'm not going to spend very
> much time on it.

In theory you should be able to submit all your files in a single ZIP archive
and entering the metadata just once, but it suddenly stopped working - see bug
#5702 (yet another reason to migrate to cchost)

Closing as duplicate.

*** This bug has been marked as a duplicate of 5619 ***