Bug 67790 - error message on suspend and hibernate: *ERROR* Could not force DPM to low
Summary: error message on suspend and hibernate: *ERROR* Could not force DPM to low
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) All
: high normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2013-08-05 13:16 UTC by Johannes Hirte
Modified: 2019-11-19 08:36 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Description Johannes Hirte 2013-08-05 13:16:21 UTC
On suspend dmesg shows the following error message:

[  236.137036] PM: Syncing filesystems ... done.
[  236.673588] Freezing user space processes ... (elapsed 0.007 seconds) done.
[  236.680901] Freezing remaining freezable tasks ... (elapsed 0.000 seconds) done.
[  236.681975] Suspending console(s) (use no_console_suspend to debug)
[  236.693223] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[  236.695019] sd 0:0:0:0: [sda] Stopping disk
[  237.336598] [drm:rv770_stop_dpm] *ERROR* Could not force DPM to low.
[  239.009616] radeon 0000:01:00.0: power state changed by ACPI to D3cold
[  239.009696] PM: suspend of devices complete after 2315.934 msecs
[  239.009861] PM: late suspend of devices complete after 0.162 msecs

I've not seen any problems, suspend and resume worked correct so far.
Comment 1 Pali Rohár 2013-08-14 09:01:08 UTC
I see same error message in dmesg with kernel 3.11-rc5 when my notebook is suspending or hibernating. But suspend and hibernate working fine. I have Radeon HD 6470M card.
[drm:rv770_stop_dpm] *ERROR* Could not force DPM to low.
Comment 2 almos 2014-12-08 14:56:55 UTC
This is printed with my Barts GPU as well, which seems to indicate that the function is slightly misnamed.
Comment 3 xorgx3 2014-12-28 10:26:16 UTC
Bug still persist in  3.18.1 kernel. And it's very annoying, because in my laptop(Radeon HD5400) I cannot return from suspend/hibernate because of this bug, and I need to restart computer...
Comment 4 Alex Deucher 2015-01-02 22:45:43 UTC
The code is shared across several generations of hardware.  As long as suspend and resume works ok, it can be ignored.
Comment 5 malt 2015-06-01 19:49:57 UTC

I have the same problem with my laptop (packard bell).

If you nend some file log i can send it to you. 
uname -a: 
Linux 3.13.0-53-generic #89-Ubuntu SMP Wed May 20 10:34:39 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

a part of my syslog:
[drm:rv730_stop_dpm] *ERROR* Could not force DPM to low

a part of lspci:
- VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV710/M92 [Mobility Radeon HD 4530/4570/545v]
- Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RV710/730 HDMI Audio [Radeon HD 4000 series]
Comment 6 Martin Peres 2019-11-19 08:36:47 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/amd/issues/361.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.