Bug 67823 - xf86-video-intel 2.21.14-1 slows down gnome-shell with SNA accelleration
Summary: xf86-video-intel 2.21.14-1 slows down gnome-shell with SNA accelleration
Status: RESOLVED DUPLICATE of bug 37686
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Chris Wilson
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-06 11:03 UTC by Volker Holthaus
Modified: 2013-08-06 14:33 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (29.02 KB, text/plain)
2013-08-06 13:42 UTC, Volker Holthaus
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volker Holthaus 2013-08-06 11:03:30 UTC
Hardware:

NVidia GT555M 

Software:

Arch Linux Kernel 3.10.3-1-ARCH
bumblebee 3.2.1-3
nvidia driver 319.32
xf86-video-intel 2.21.14-1

If i change the accelleration from UXA to SNA the gnome-shell slows dramatically down. No error in the Xorg.0.log or dmesg log.

With the UXA accelleration everything works fine.
Comment 1 Volker Holthaus 2013-08-06 11:06:14 UTC
Xorg 1.14.2-2
Comment 2 Chris Wilson 2013-08-06 12:01:32 UTC
The obvious candidate is 

commit 3f04b6f33f05f8a24698f934a23462269b84917d
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Thu Aug 1 14:49:36 2013 +0100

    sna/dri: Disable TripleBuffering by default for compositors

which is more or less at the request of the gnome-shell authors.
Comment 3 Chris Wilson 2013-08-06 12:03:19 UTC
(Except you didn't actually say this was a regression. And haven't even attached the Xorg log or stated the exact nature of the slowdown).
Comment 4 Volker Holthaus 2013-08-06 13:42:18 UTC
Created attachment 83719 [details]
Xorg.0.log
Comment 5 Volker Holthaus 2013-08-06 13:42:46 UTC
The regression was the slow animation of the windows, when you change to the activity screen and choose workplace with another application.
The applications behavior is normal.
Comment 6 Chris Wilson 2013-08-06 14:33:20 UTC
Option "TearFree" "true"

That's wip and definitely something you do not need whilst running gnome-shell.

*** This bug has been marked as a duplicate of bug 37686 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.