Bug 67979 - xdg-email - does not open mail client under xfce
Summary: xdg-email - does not open mail client under xfce
Status: NEW
Alias: None
Product: Portland
Classification: Unclassified
Component: xdg-utils (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium major
Assignee: Portland Bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-10 10:09 UTC by XELfmomrmbug
Modified: 2013-08-10 10:21 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Fix for 1.1.0 rc1 - output from git diff (1.29 KB, text/plain)
2013-08-10 10:09 UTC, XELfmomrmbug
Details
Canidate fix for 1.0.2 - Instrumented code (1.54 KB, text/plain)
2013-08-10 10:13 UTC, XELfmomrmbug
Details

Note You need to log in before you can comment on or make changes to this bug.
Description XELfmomrmbug 2013-08-10 10:09:03 UTC
Created attachment 83922 [details]
Fix for 1.1.0 rc1 - output from git diff

In Xubuntu 13.04 (Raring Ringtail) xdg-email fails and presents an error dialog stating 'Unable to detect the URI-scheme of "mailto:".'.

I observed this problem when using "Simple Scan" in this environment.

The problem is that exo-open does not support the mailto URI.

Versions this problem occurs in
===============================

Xubuntu 13.04 uses version 1.0.2 of xdg-utils.

This problem also occurs in 1.1.0 rc1 of xdg-utils.

How to reproduce
================

Run xdg-email from command line in Xubuntu 13.04.

Fixes
=====

I will attach canidate patches for 1.1.0 rc1 and 1.0.2.
Comment 1 XELfmomrmbug 2013-08-10 10:13:56 UTC
Created attachment 83923 [details]
Canidate fix for 1.0.2 - Instrumented code

Sorry about the accidental formatting changes.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.