Bug 6805 - glxgears "jumps" when window loses focus
Summary: glxgears "jumps" when window loses focus
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: General (show other bugs)
Version: XOrg git
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-02 00:58 UTC by Daniel Baulig
Modified: 2019-10-14 13:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Screenshot of glxgears before the bugs appears (21.71 KB, image/png)
2006-05-02 01:00 UTC, Daniel Baulig
no flags Details
Screenshot of glxgears after the bug appears (6.99 KB, image/png)
2006-05-02 01:02 UTC, Daniel Baulig
no flags Details
my xorg.conf (5.08 KB, text/plain)
2006-05-02 01:03 UTC, Daniel Baulig
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Baulig 2006-05-02 00:58:11 UTC
I have xorg7.0 running on Debian Linux on my T30 with Radeon 7500 Mobility (M7
LW). When I run glxgears everything works fine until the glxgears window is
overshadowed by any other window. Suddenly the gears in the window pop away from
their initial position and reposition themselves in the left corner of the
glxgears window. As soon as I move the glxgears window, the gears reappear at
their correct position. After some testing it appears as if the new center of
the gears isn't the center of the glxgears window anymore, but the left edge of
the display. So, if I move the glxgears window away from the left edge and set
it into the background the gears disappear completely and if I move the glxgears
window over the left edge of the screen the gears even pop to the right as soon
as the window is set to background. I have made some screenshots to clarify what
the situation looks like. I will add my xorg.conf aswell. If anything else is
needed, let me know.
Comment 1 Daniel Baulig 2006-05-02 01:00:38 UTC
Created attachment 5539 [details]
Screenshot of glxgears before the bugs appears

This screenshot sow glxgears window in it's normal behaviour before the bug
appears.
Comment 2 Daniel Baulig 2006-05-02 01:02:59 UTC
Created attachment 5540 [details]
Screenshot of glxgears after the bug appears

This screenshot shows the glxgears window after it is set to backround and the
bug appears. Note that this window was positioned at the left edge of the
screen when the gears "moved" out of the glxgears window (the center of the
gears is now positioned approx. where the screen ends).
Comment 3 Daniel Baulig 2006-05-02 01:03:40 UTC
Created attachment 5541 [details]
my xorg.conf
Comment 4 Michel Dänzer 2006-05-02 01:19:03 UTC
Which version of Mesa? (glxinfo|grep version)

A problem that could cause symptoms like this has been fixed shortly before the
Mesa 6.5 release.
Comment 5 Daniel Baulig 2006-05-02 01:31:38 UTC
the output is as follows:

server glx version string: 1.2
client glx version string: 1.4
GLX version: 1.2
OpenGL version string: 1.2 Mesa 6.4.1
glu version: 1.3

It seems that my MESA is outdated then, or am I wrong? When I try to apt-get
install a more recent version of the MESA packages, it tells me though, my
packages are up to date. May I need to get CVS MESA?
Comment 6 Corbin Simpson 2010-03-27 04:53:18 UTC
Bump? Haven't heard back from the reporter in a while. I'll close this if we don't hear back from him in a bit, but I'll wait. Gears are serious business, after all.
Comment 7 Daniel Baulig 2010-03-27 05:07:54 UTC
I am still around, but since this report was never updated anymore and no further information was requested I saw no point in having a monologue ;)
Since I actually did not need any 3D acceleartion on my notebook I never continued on investigating this for myself. But since Michael suggested that this (or a similiar) bug was fixed in MESA 6.5 I'd say go ahead and close it and if it never arises again it propably was fixed.
Comment 8 Martin Peres 2019-10-14 13:20:08 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.