Bug 6818 - For EXA_OFFSCREEN_ALIGN_POT, exaLog2 goes into endless loop.
For EXA_OFFSCREEN_ALIGN_POT, exaLog2 goes into endless loop.
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Server/Acceleration/EXA
git
x86 (IA32) Linux (All)
: high normal
Assigned To: Xorg Project Team
:
: 6854 (view as bug list)
Depends on:
Blocks: 6877
  Show dependency treegraph
 
Reported: 2006-05-03 04:45 UTC by George -
Modified: 2006-06-24 06:41 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
avoid endless loop (510 bytes, patch)
2006-06-20 19:19 UTC, George -
no flags Details | Splinter Review
Extend sanity check in exaLog2 for negative numbers (251 bytes, patch)
2006-06-21 01:29 UTC, Michel Dänzer
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description George - 2006-05-03 04:45:58 UTC
This is because it is called with w=0 (for glyphs, as per comment a few lines
above).
Comment 1 Thomas Hellström 2006-05-23 09:38:00 UTC
*** Bug 6854 has been marked as a duplicate of this bug. ***
Comment 2 George - 2006-06-20 19:19:18 UTC
Created attachment 6000 [details] [review]
avoid endless loop
Comment 3 Michel Dänzer 2006-06-21 01:29:07 UTC
Created attachment 6002 [details] [review]
Extend sanity check in exaLog2 for negative numbers

How about this one instead, to avoid similar issues in the future?
Comment 4 Michel Dänzer 2006-06-24 06:41:33 UTC
I pushed my patch.