Bug 68272 - table dependencies has no column named items_installed
Summary: table dependencies has no column named items_installed
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: All All
: high critical
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-19 12:15 UTC by Jacek Szafarkiewicz
Modified: 2014-11-07 11:57 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jacek Szafarkiewicz 2013-08-19 12:15:22 UTC
When I try to run almost any command I recive error:
$ pkcon get-updates
Getting updates               [=========================]         
Waiting in queue              [=========================]         
Starting                      [=========================]         
Fatal error: Unable to open database read-only: Database action 'prepare dependency insert statement' failed: table dependencies has no column named items_installed
Comment 1 zk3e 2013-08-24 16:58:30 UTC
I have the same problem with apper in debian testing.
Comment 2 antond1989 2013-09-04 08:37:29 UTC
I've got a same issue on debian unstable.
ximion, the developer of listaller, suggests to execute "rm -r ~/.local/share/software;sudo rm -r /var/lib/listaller/db/" and it helped!
Comment 3 Jacek Szafarkiewicz 2013-09-04 08:51:08 UTC
I don't have ~/.local/share/software, but deleting /var/lib/listaller/db/ worked for me.
Thanks

Developers could add auto delete if such errors
Comment 4 MAG4 2013-09-06 07:18:08 UTC
Hi, we also solved deleting /var/lib/listaller/db/
Regards!
Comment 5 Matthias Klumpp 2014-11-06 18:42:30 UTC
This is fixed in more recent releases of PackageKit and Listaller (and won't ever happen again for other reasons anyway)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.