Bug 6881 - Evince (via poppler) crashes when viewing a specific pdf in fullscreen
Summary: Evince (via poppler) crashes when viewing a specific pdf in fullscreen
Status: RESOLVED FIXED
Alias: None
Product: poppler
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-10 11:28 UTC by Andy Delcambre
Modified: 2009-09-15 15:41 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Delcambre 2006-05-10 11:28:59 UTC
When viewing a very specific area in a single pdf, evince crashes on my up to
date dapper box.  The pdf that crashes it is an ebook I purchased so I am not
including it, but I will email it to a developer if they need it.  

It is "Agile Web Developement with Rails: Second Edition" Beta Book from 
http://pragmaticprogrammer.com/

It crashes when scrolling past page 71.  It only crashes when evince is maximised.

The error that I get is:
  Bogus memory allocation size
Comment 1 Albert Astals Cid 2006-05-11 03:29:12 UTC
"It only crashes when evince is maximised."

That would seem to me that is an evince bug and not a poppler one, but without 
the document there's nothing to be done.
Comment 2 Alex Chekholko 2006-07-01 15:40:18 UTC
I have just encountered the same bug and also filed it here:
https://launchpad.net/distros/ubuntu/+source/evince/+bug/51538
Comment 3 Albert Astals Cid 2009-06-17 14:07:38 UTC
Any chance you can try with a newer poppler?
Comment 4 Adam Buchbinder 2009-07-22 06:40:18 UTC
It's definitely a Poppler issue. I can reproduce this with poppler 0.11.1 thusly:

$ pdfimages --version
pdfimages version 0.11.1
[snip]
$ pdfimages 1972.pdf tmp
Error (147774): 3 extraneous bytes after segment
Bogus memory allocation size

The PDF in question is 1972.pdf; it's linked to from the following URL:

http://doddcenter.uconn.edu/collections/nutmeg/index.htm

I'm not attaching it here because it's 18MB, and also because I'm not sure how redistributable it is. The file I have was last modified Thu, 11 Jun 2009 20:08:45 GMT, and has md5sum 9ee38b8f90dbe343163f9927d37c35bd.
Comment 5 Albert Astals Cid 2009-07-31 13:27:32 UTC
Why was this posted here? What relation does this has with the first post?
Comment 6 Albert Astals Cid 2009-09-15 15:41:18 UTC
The first report in this bug never seemed a poppler bug and the second one works here on poppler 0.12 so i'm closing the bug.

If any of you still have problems after updating to poppler >= 0.12 please open a new bug and explain it again.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.