Bug 69288 - xorg-server-1.14.2.902: BUG: Non-emulating touch event
Summary: xorg-server-1.14.2.902: BUG: Non-emulating touch event
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Input/Core (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 96775 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-12 19:51 UTC by Peter
Modified: 2018-12-17 17:26 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (282.20 KB, text/plain)
2013-09-12 19:51 UTC, Peter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2013-09-12 19:51:10 UTC
Created attachment 85740 [details]
Xorg.0.log

[   310.114] (EE) BUG: triggered 'if (!(event->device_event.flags & (1 << 5)))'
[   310.114] (EE) BUG: /var/tmp/portage/x11-base/xorg-server-1.14.2.902-r1/work/xorg-server-1.14.2.902/dix/touch
.c:644 in TouchConvertToPointerEvent()
[   310.114] (EE) Non-emulating touch event
[   310.114] (EE) 
[   310.114] (EE) Backtrace:
[   310.114] (EE) 0: /usr/bin/Xorg (xorg_backtrace+0x47) [0x7fe1f219bda7]
[   310.114] (EE) 1: /usr/bin/Xorg (0x7fe1f1fc8000+0x875f7) [0x7fe1f204f5f7]
[   310.114] (EE) 2: /usr/bin/Xorg (0x7fe1f1fc8000+0x158c19) [0x7fe1f2120c19]
[   310.114] (EE) 3: /usr/bin/Xorg (0x7fe1f1fc8000+0x15832c) [0x7fe1f212032c]
[   310.114] (EE) 4: /usr/bin/Xorg (0x7fe1f1fc8000+0x15b62f) [0x7fe1f212362f]
[   310.114] (EE) 5: /usr/bin/Xorg (0x7fe1f1fc8000+0x18111f) [0x7fe1f214911f]
[   310.114] (EE) 6: /usr/bin/Xorg (mieqProcessDeviceEvent+0x1b5) [0x7fe1f217ae15]
[   310.115] (EE) 7: /usr/bin/Xorg (mieqProcessInputEvents+0x10b) [0x7fe1f217af4b]
[   310.115] (EE) 8: /usr/bin/Xorg (ProcessInputEvents+0x19) [0x7fe1f2067509]
[   310.115] (EE) 9: /usr/bin/Xorg (0x7fe1f1fc8000+0x58092) [0x7fe1f2020092]
[   310.115] (EE) 10: /usr/bin/Xorg (0x7fe1f1fc8000+0x44a8a) [0x7fe1f200ca8a]
[   310.115] (EE) 11: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7fe1f01c1905]
[   310.115] (EE) 12: /usr/bin/Xorg (0x7fe1f1fc8000+0x44de5) [0x7fe1f200cde5]

Or with resolved functions:

0: /usr/bin/Xorg (xorg_backtrace+71) [0x7fe1f219bda7]                           
1: /usr/bin/Xorg (TouchConvertToPointerEvent + 439)                             
2: /usr/bin/Xorg (DeliverTouchEmulatedEvent.isra.11.part.12 + 105)              
3: /usr/bin/Xorg (DeliverTouchEvents + 700)                                     
4: /usr/bin/Xorg (ProcessOtherEvent + 1007)                                     
5: /usr/bin/Xorg (ProcessPointerEvent + 239)                                    
6: /usr/bin/Xorg (mieqProcessDeviceEvent+0x1b5)                                 
                                                                                
7: /usr/bin/Xorg (mieqProcessInputEvents+0x10b)                                 
                                                                                
8: /usr/bin/Xorg (ProcessInputEvents + 25)                                      
9: /usr/bin/Xorg (Dispatch + 146)                                               
10: /usr/bin/Xorg (main + 986) [0x7fe1f200ca8a]                                 
11: /lib64/libc.so.6 (__libc_start_main+0xf5)            
12: /usr/bin/Xorg (_start + 41) [0x7fe1f200cde5]

I failed to find exact steps to reproduce the problem but I easily reproduce it here. I'm running gnome-3.8 (gnome-shell-3.8.4) on ThinkPad X230.
Comment 1 Ritesh Raj Sarraf 2016-07-01 21:48:49 UTC
I have the same bug consistently reproduced on a touchscreen setup. If I use 2 fingers to swipe on my touchscreen, the crash is triggered.

I reported the bug @ https://bugs.freedesktop.org/show_bug.cgi?id=96775
and then saw your bug report.
Comment 2 Ritesh Raj Sarraf 2016-07-01 21:50:04 UTC
*** Bug 96775 has been marked as a duplicate of this bug. ***
Comment 3 GitLab Migration User 2018-12-17 17:26:31 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/570.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.