Bug 69670 - KWin crashes when switching to OpenGL 3.1 + Raster
Summary: KWin crashes when switching to OpenGL 3.1 + Raster
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: 9.2
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2013-09-22 10:00 UTC by Eugene
Modified: 2018-03-31 21:57 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

kwin stderr (8.58 KB, text/plain)
2013-09-22 10:00 UTC, Eugene
dmesg (70.92 KB, text/plain)
2013-09-22 10:01 UTC, Eugene
kwin stdout (756 bytes, text/plain)
2013-09-22 10:02 UTC, Eugene
Xorg log (62.19 KB, text/plain)
2013-09-22 10:02 UTC, Eugene
kwin stderr with LIBGL_ALWAYS_SOFTWARE=1 (21.56 KB, text/plain)
2013-09-29 12:16 UTC, Eugene

Description Eugene 2013-09-22 10:00:46 UTC
Created attachment 86306 [details]
kwin stderr

KWin crashes with the following message after switching from OpenGL 2.0 + Raster to OpenGL 3.1 + Raster:

[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
kwin: xcb_io.c:274: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.

Some information about the system (Arch Linux x86_64):

$ uname -srvm
Linux 3.11.1-1-ARCH #1 SMP PREEMPT Sat Sep 14 19:30:21 CEST 2013 x86_64

$ sudo lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn XT [Radeon HD 7870 GHz Edition]

$ yaourt -Qs mesa | egrep '^[^ ]'
extra/ati-dri 9.2.0-2
extra/glu 9.0.0-2
multilib/lib32-ati-dri 9.2.0-1
multilib/lib32-glu 9.0.0-2
multilib/lib32-libtxc_dxtn 1.0.1-5
multilib/lib32-mesa 9.2.0-1
multilib/lib32-mesa-libgl 9.2.0-1
extra/mesa 9.2.0-2
extra/mesa-demos 8.1.0-1
extra/mesa-libgl 9.2.0-2

$ yaourt -Qs xf86-video-ati
extra/xf86-video-ati 1:7.2.0-1 (xorg-drivers xorg)

# cat /etc/X11/xorg.conf.d/05-glamor.conf 
Section "Module"
        Load  "dri2"
        Load  "glamoregl"

# cat /etc/X11/xorg.conf.d/50-device.conf 
Section "Device"
  Identifier "Default Device"
  Driver "radeon"
  Option "SwapbuffersWait" "off"
  Option "ColorTiling" "on"
  Option "ColorTiling2D" "on"
  Option "EnablePageFlip" "on"
  Option "AccelDFS" "on"                                                                                                            
  Option "XV_VSYNC" "on"                                                                                                            
  Option "AccelMethod" "glamor"                                                                                                     
  #Option "AccelMethod" "EXA"                                                                                                       
Comment 1 Eugene 2013-09-22 10:01:53 UTC
Created attachment 86307 [details]
Comment 2 Eugene 2013-09-22 10:02:13 UTC
Created attachment 86308 [details]
kwin stdout
Comment 3 Eugene 2013-09-22 10:02:36 UTC
Created attachment 86309 [details]
Xorg log
Comment 4 Michel Dänzer 2013-09-26 17:44:08 UTC
As you can see in the kwin stdout output, radeonsi only supports OpenGL 2.1 in Mesa 9.2. I suspect the problem happens when kwin tries to create an OpenGL 3.x context, but I wonder if this is radeonsi specific — does it not happen e.g. if you run kwin with LIBGL_ALWAYS_SOFTWARE=1 ?
Comment 5 Eugene 2013-09-29 12:15:37 UTC
I am not sure how to confirm it. I tried launching:

LIBGL_ALWAYS_SOFTWARE=1 kwin --replace > kwin_stdout_LIBGL_ALWAYS_SOFTWARE.txt 2> kwin_stderr_LIBGL_ALWAYS_SOFTWARE.txt

and it disabled desktop effects; then I tried to switch to OpenGL 3.1 + Raster and Kwin crashed displaying 'report bug assignment'  window and then was restarted automatically without effects. I could not enable effect anyhow.

kwin_stdout_LIBGL_ALWAYS_SOFTWARE.txt was empty.
Comment 6 Eugene 2013-09-29 12:16:29 UTC
Created attachment 86794 [details]
kwin stderr with LIBGL_ALWAYS_SOFTWARE=1
Comment 7 smoki 2015-01-31 15:55:35 UTC
 Pretty much old bug, is this still an issue with current mesa?
Comment 8 Timothy Arceri 2018-03-31 21:57:28 UTC
As per comment 4 radeonsi in 2013 probably didn't support the required OpenGL support. Closing.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.