Bug 69728 - Radeon Redwood (5670) GPU Lockup
Summary: Radeon Redwood (5670) GPU Lockup
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: 9.2
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2013-09-23 18:52 UTC by pablow.1422
Modified: 2019-09-18 19:05 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

journalctl log (12.02 KB, text/plain)
2013-09-23 18:52 UTC, pablow.1422
another journalctl log (12.70 KB, text/plain)
2013-09-23 18:54 UTC, pablow.1422
This is another dmesg log (42.35 KB, text/plain)
2013-09-24 01:18 UTC, pablow.1422
Mesa compile flags (2.34 KB, text/plain)
2013-09-24 15:01 UTC, pablow.1422

Description pablow.1422 2013-09-23 18:52:50 UTC
Created attachment 86404 [details]
journalctl log

When running a 3D Game, like 0A.D. or Need for Speed Most Wanted or Counter Strike 1.6, both over wine, after a variable leght of time I get a GPU Lockup. While playing Counter Strike 1.6 sometimes I can get into a tty and kill exe process, which allows me to be able to use the desktop.
If not, a completely system hang happens, but I can ssh in, thus is how I've obtained dmesg log (actually from journalctl).

This hang always happen also when I use accelerated flash games in Chrome or Firefox (11.6 11.2 flash versions).

I have no issues in normal desktop usage, or when playing FullHD videos using VDPAU.

My system is a AMD Phenom II x6 1100T; AMD Radeon HD 5670 (MSI) running Fedora pre-release 20: Kernel 3.11, DPM and UVD enabled, mesa 9.2.0, wine 1.7.1, KDE 4.11 with kwin using OpenGL 3.1 compositing.

Aditional Info: The hang occurs using kernel 3.11, 3.10, 3.9 with UVD and DPM enabled or disabled, kwin using OpenGL 3.1, 2.0 or 1.2 and bypassing (or not) desktop compositing with fullscreen apps.

I can provide any aditional info that could help.
PD: sorry my english.
Comment 1 pablow.1422 2013-09-23 18:54:00 UTC
Created attachment 86405 [details]
another journalctl log
Comment 2 Alex Deucher 2013-09-23 22:18:30 UTC
Does disabling hyperZ help?  E.g., set env var:
Comment 3 pablow.1422 2013-09-24 00:00:25 UTC
Already tried that. It doesn't help.
Comment 4 pablow.1422 2013-09-24 01:18:09 UTC
Created attachment 86426 [details]
This is another dmesg log

...but this one if from a lockup which I could recover from, switching to a tty and killing the wineserver and exe proceses.
Comment 5 Alex Deucher 2013-09-24 13:53:54 UTC
You might also try:

Also did you build mesa with opencl or llvm support?  If so, does disabling llvm help?

Comment 6 pablow.1422 2013-09-24 15:01:04 UTC
Created attachment 86456 [details]
Mesa compile flags

It looks like it was compiled against llvm (I use standard Fedora 20 packages, this build log is what I get from koji build system).

But, I've tried all you suggested with no luck.
Comment 7 pablow.1422 2013-09-29 00:43:54 UTC
I've done what you suggested with Mesa 9.3.0-devel (git-a64d3dd), the GPU lockup still occurs. Is there anything more that I could try?
Comment 8 pablow.1422 2013-11-24 23:48:04 UTC
Sorry to bump.. but this bug have became very frustating. Now watching videos with flash cant be done without a lockup ocurring aproximately 20% of times (with rendering relying on GPU, software decoding). With fglrx it's OK.

It's there anything I could do from here? Just point me to the right direction and I'll try asist in chasing down this bug, no matter what time does it takes from me.


To add: I'm now using Kubuntu, with latest git mesa from oibaf ppa.
Comment 9 Alex Deucher 2013-11-25 18:17:11 UTC
(In reply to comment #8)
> Sorry to bump.. but this bug have became very frustating. Now watching
> videos with flash cant be done without a lockup ocurring aproximately 20% of
> times (with rendering relying on GPU, software decoding). With fglrx it's OK.

Are you using adobe's flash player?  Do you still get lockups using something other than adobe's flash player?  It's known to be buggy.
Comment 10 pablow.1422 2013-11-25 18:32:35 UTC
Actually, using adobe flash 11.2 wich is the latest usable version with firefox didn't bring a lockup, only adobe version 11.9 (PPAPI) with google chrome did.

Still, all the issues I had described in previous post still happens, like: Wine Games (counter strike 1.6 wich I belive is OpenGL 2.0), O AD, Xonotic causing a total system hang, after trying to reset the GPU several times (as I could see from the logs). To add, normal desktop usage (without counting the adobe flash issues) like libreoffice gpu acceleration, vdpau video player, Kwin composited, etc it's in good shape. 

I've also tried set env var R600_DEBUG=nohyperz; R600_DEBUG=nodma; R600_DEBUG=nosb; R600_LLVM=0 with no luck.
Comment 11 Vedran Miletić 2017-03-22 15:36:35 UTC
Is this still an issue?
Comment 12 pablow.1422 2017-03-23 15:55:55 UTC
(In reply to Vedran Miletić from comment #11)
> Is this still an issue?

Hi! I no longer have that video card, so no idea if it's still an issue.
Comment 13 GitLab Migration User 2019-09-18 19:05:45 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/464.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.