account.c and connection-manager.c has a few FIXME about tp 1.0, we should review & fix them.
If they're FIXMEs about 1.0, then our past selves obviously thought it would be a compatibility break to fix them. We should get the initial round of 'next' branches working first, so we have a working state for the whole system.
The FIXMEs appear to be
* remove tp_account_get_storage_identifier and rename
tp_account_dup_storage_identifier (or maybe make it a const "get")
* remove tp_account_get_storage_specific_information_async and
(the FIXME comment wanted it to be a const "get" but I don't know why)
* rename tp_connection_manager_dup_protocols to get_protocols
(but I think that's been superseded by agreeing that our policy is
"if in doubt, (transfer full) and call it _dup")
Not rocket surgery.
(In reply to comment #3)
Indeed, not rocket surgery. Looks fine.