Bug 6983 - UIM background setting
Summary: UIM background setting
Status: RESOLVED FIXED
Alias: None
Product: UIM
Classification: Unclassified
Component: bridge: GTK+ (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: uim-bugs
QA Contact:
URL: http://bugs.debian.org/cgi-bin/bugrep...
Whiteboard:
Keywords: patch
Depends on:
Blocks: 6089
  Show dependency treegraph
 
Reported: 2006-05-20 19:06 UTC by Osamu Aoki
Modified: 2006-05-22 06:12 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
corrupted uim applet appearance (1) (4.43 KB, image/png)
2006-05-21 21:52 UTC, YamaKen
Details
corrupted uim applet appearance (2) (2.55 KB, image/png)
2006-05-21 21:53 UTC, YamaKen
Details
normal uim applet appearance (2.82 KB, image/png)
2006-05-21 21:53 UTC, YamaKen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Osamu Aoki 2006-05-20 19:06:44 UTC
Forwarding Debian bug report with patch to upstream.
As I looked newer 1.0.0, code seems to be in the same shape.
----
Package: uim-applet-gnome
Version: 1:0.4.7-1
Severity: minor
Tags: patch

The look of uim applet does not react to changes in the background of a panel,
so looks a little weird on transparent panels.  Attached is a patch that is
borrowed from gnome-applets' source
(gnome-applets-2.10.1/gweather/gweather-applet.c).

-- 
Masaki Oita <m-oita@nifty.com>

See patch at http://bugs.debian.org/321705
Comment 1 YamaKen 2006-05-21 12:07:52 UTC
Thanks for the report. The bug is reproduced.

But on my environment, the patch shows corrupted image on the applet.
Although I'm not familiar with GTK+ programming, it looks something wrong
compared with the original code.
http://www.koders.com/c/fid529F1CDE56ABEC96599C5963FB766AD7E4C64C65.aspx#L122
Comment 2 Etsushi Kato 2006-05-21 20:05:54 UTC
OK.  Now I've committed the fix with pluging one leak.

I've checked this works fine on gtk+-2.9.1 (Fedora rawhide).

Thanks,
-- 
Etsushi Kato
Comment 3 YamaKen 2006-05-21 21:52:29 UTC
Created attachment 5701 [details]
corrupted uim applet appearance (1)
Comment 4 YamaKen 2006-05-21 21:53:00 UTC
Created attachment 5702 [details]
corrupted uim applet appearance (2)
Comment 5 YamaKen 2006-05-21 21:53:45 UTC
Created attachment 5703 [details]
normal uim applet appearance
Comment 6 YamaKen 2006-05-21 22:01:41 UTC
Although it normally displayed on first repetition of the pixmap, it is
corrupted on 2nd and subsequent tile-patterned repetition of the image. See
attached PNG files.

My environment is GNOME 2.12.3 and GTK+ 2.8.12 installed from FreeBSD ports.
Comment 7 Etsushi Kato 2006-05-21 22:44:01 UTC
Hmm...  The patch uses the same way as in gnome-volume-manager applet.  How does
it works on your environment?
Comment 8 YamaKen 2006-05-21 22:56:54 UTC
Both the volume control and weather report applets are corrupted alike uim applet.
So uim applet should be rewritten to 'proper' way.

Does the two works properly on your environment? As I mentioned in comment #1,
newer? version of the weather report applet has a different handler.

http://www.koders.com/c/fid529F1CDE56ABEC96599C5963FB766AD7E4C64C65.aspx#L122
Comment 9 Etsushi Kato 2006-05-22 00:02:02 UTC
> Does the two works properly on your environment? As I mentioned in comment #1,
> newer? version of the weather report applet has a different handler.

Yep.  Both work fine, as uim applet works without problem on gtk+-2.9.1.

I checked that volume manager applet in gnome-applets 2.14.1 (current stable
version) has the same routine I've committed.  And gweather-applet.c,v 1.105
2006/02/01 14:57:01 doesn't have the handler in Koders' one.  It is removed and
uses libgnome-panel's routine right now.

Also I've found a notes in ChangeLog of gwether

2004-02-26  Dennis Smit  <ds@nerds-incorporated.org>

        * gweather-applet.c (gweather_applet_create):
        Connect a signal to change_background.

        (change_background_cb):
        Added function and handle background changes.
        Doesn't work for pixmap backgrounds yet.

I'll dig more later.
Comment 10 Etsushi Kato 2006-05-22 00:18:16 UTC
Could you try r3472?
Comment 11 Etsushi Kato 2006-05-22 00:41:57 UTC
FYI, panel_applet_set_background_widget() API is available only
gnome-panel-2.14.x and later.
Comment 12 YamaKen 2006-05-22 00:59:31 UTC
Currently it cannot compile due to the GNOME version problem. Please enclose the
panel_applet_set_background_widget() into a conditional compilation fragment
like GTK_CHECK_VERSION() (I don't know such thing for GNOME).

I'm upgrading my GNOME to 2.14 and I'll report the result once it finished.
Comment 13 Etsushi Kato 2006-05-22 01:15:41 UTC
OK.  I'll modify configure.ac.
Comment 14 YamaKen 2006-05-22 23:12:14 UTC
I've updated GNOME to 2.14, and the your latest code works fine. Thank you.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.