Bug 69952 - [NVAA] Xorg crash+restart after glxgears on 3.12-rc2
Summary: [NVAA] Xorg crash+restart after glxgears on 3.12-rc2
Status: NEEDINFO
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-30 09:47 UTC by dirkneukirchen
Modified: 2015-02-19 10:30 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
3.12-rc2 Xorg crash when running glxgears (1.19 MB, text/plain)
2013-09-30 09:47 UTC, dirkneukirchen
no flags Details
dmesg after crash of Xorg when running glxgears (836.96 KB, text/plain)
2013-11-22 11:19 UTC, dirkneukirchen
no flags Details
Same error on kernel 3.13-rc2 (742.99 KB, text/plain)
2013-12-06 22:51 UTC, dirkneukirchen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description dirkneukirchen 2013-09-30 09:47:29 UTC
Created attachment 86837 [details]
3.12-rc2 Xorg crash when running glxgears

How to replicate:
- booting and doing random desktop stuff

- 1st errors in log: TRAP_TPDMA_2D
thats "normal"/possibly dangerous too:
occured with playing video: mplayer -vo xv -ao sdl 
mplayer: MPlayer svn r34540 (Ubuntu), built with gcc-4.7 (C) 2000-2012 MPlayer Team


later Crash in log:
- open glxgears on 1st virtual desktop
- switch to 4th virtual desktop 
- open rdesktop program
- xorg is nonresponsive - try keyboard shortcuts to change desktop (dont work)
- wait until Xorg is restarted 

System:
-Linux Mint 15 (Ubuntu 13.04)
-NVAA (Geforce 8200) onboard (Jetway JNC62K)
-dual monitor setup

-Kernel 3.12-rc2

The attached dmesg contains several error messages that are missing from 68037 or are added compared to 69387.
It could be the same "bug"/"bugs" that are described in 68037.
Accel. Video often freeze, stability is increased when playing with x11(without overlay) in vlc or mplayer. But that might be subjective.

possibly related:
https://bugs.freedesktop.org/show_bug.cgi?id=68037 (same setup from me)
https://bugs.freedesktop.org/show_bug.cgi?id=69387
Comment 1 dirkneukirchen 2013-10-15 17:04:19 UTC
mmio traces:

filed in another bug (https://bugs.freedesktop.org/show_bug.cgi?id=69928)
on the same hw:

module load:
https://bugs.freedesktop.org/attachment.cgi?id=87677


simple xinit with sleep:
mmiotrace_xinit.log.xz (3.1 MB)
https://mega.co.nz/#!u4RwFLjK!Yzi4UVujupmRdEIMFZtbQBOtjyoJFR1jrXheO1RUpew

starting glxgears:
mmiotrace_glxgears.log.xz (3.4 MB)
https://mega.co.nz/#!744wlQ7b!CBnbnEYfsIwOuXKFojgy3kuecVkC6U43Bye4nZkKMUk

starting nvidia-settings - since dual screen is active already just browse through options and then quit:
mmiotrace_dualsettings.log.xz (2.7 MB)
https://mega.co.nz/#!L1ZR3ApZ!XEuYymYmvLyQSQdpwQ0HaiBEipp2CBHz9y3PHNBNn6Q


glxgears posted because: https://bugs.freedesktop.org/show_bug.cgi?id=69952
Comment 2 Emil Velikov 2013-11-18 16:49:35 UTC
Does posting the card [1] resolve this and/or any of your other bugs ?

Cheers,
Emil

[1] Try either one of the below two
* via the kernel command line - append nouveau.config=NvForcePost=1
* s2ram before running any test - mplayer/glxgears
Comment 3 dirkneukirchen 2013-11-22 11:10:36 UTC
I enabled posting via kernel cmdline.

cat /proc/cmdline:

BOOT_IMAGE=/vmlinuz-3.12.0 root=UUID=c52e229d-be9c-4d85-b262-5085459dc2d9 ro rootflags=subvol=@ sysrq_always_enabled ignore_loglevel debug log_buf_len=5M nouveau.config=NvMSI=0 nouveau.config=NvForcePost=1 sysrq_always_enabled


The crash still occurs:
- LXDE running glxgears
- XFCE running glxgears

Running on KDE : running glxgears "freezes" / makes the Desktop very slow but it does not crash Xorg there.

System:
-Linux Mint 15 (Ubuntu 13.04)
-NVAA (Geforce 8200) onboard (Jetway JNC62K)
-dual monitor setup (HDMI+VGA)

-Kernel 3.12.0

Steps to replicate this time:
- Login to desktop (XFCE, dual screen)
- in open terminal window : run glxgears
- switch to other virtual desktop
- Xorg hangs, crash (login screen reappers)
Comment 4 dirkneukirchen 2013-11-22 11:19:15 UTC
Created attachment 89628 [details]
dmesg after crash of Xorg when running glxgears

the log contains more debug info; cmdline had "nouveau.debug=trace drm.debug=14"

[  190.676020] nouveau E[glxgears[3270]] failed to idle channel 0xcccc0000 [glxgears[3270]]
[  205.676014] nouveau E[glxgears[3270]] failed to idle channel 0xcccc0000 [glxgears[3270]]
[  205.676119] nouveau E[     PFB][0000:02:00.0] trapped read at 0x0020012020 on channel 0x0000797f [unknown] SEMAPHORE_BG/PFIFO_READ/00 reason: PAGE_NOT_PRESENT

after that many:
nouveau E[  PGRAPH][0000:02:00.0]  ILLEGAL_MTHD ILLEGAL_CLASS
Comment 5 dirkneukirchen 2013-12-06 22:51:42 UTC
Created attachment 90379 [details]
Same error on kernel 3.13-rc2

Kernel 3.13-rc2 has it too 

complete log attached with nouveau trace enabled; possibly interesting snippets (these were seen previously too):
[   47.726763] nouveau E[   PFIFO][0000:02:00.0] DMA_PUSHER - ch 2 [Xorg[2244]] get 0x0020016b30 put 0x0020016b4c ib_get 0x0000024b ib_put 0x000002a9 state 0x80000030 (err: INVALID_CMD) push 0x00400040
[   47.810523] nouveau E[  PGRAPH][0000:02:00.0] DATA_ERROR INVALID_VALUE
[   47.810545] nouveau E[  PGRAPH][0000:02:00.0]  DATA_ERROR
[   47.810565] nouveau E[  PGRAPH][0000:02:00.0] ch 2 [0x0007b45000 Xorg[2244]] subc 2 class 0x502d mthd 0x08d4 data 0x00144230
[  131.224959] nouveau E[   PFIFO][0000:02:00.0] DMA_PUSHER - ch 2 [Xorg[2244]] get 0x002002b068 put 0x002002b11c ib_get 0x0000016c ib_put 0x000001bb state 0x800048e0 (err: INVALID_CMD) push 0x00400040
[  131.392877] nouveau E[  PGRAPH][0000:02:00.0] DATA_ERROR INVALID_VALUE
[  131.392898] nouveau E[  PGRAPH][0000:02:00.0]  DATA_ERROR
[  131.392918] nouveau E[  PGRAPH][0000:02:00.0] ch 2 [0x0007b45000 Xorg[2244]] subc 2 class 0x502d mthd 0x08dc data 0x00144230


[  162.340013] nouveau E[Xorg[2244]] failed to idle channel 0xcccc0000 [Xorg[2244]]
[  177.340015] nouveau E[Xorg[2244]] failed to idle channel 0xcccc0000 [Xorg[2244]]
[  207.520133] nouveau E[     PFB][0000:02:00.0] trapped read at 0x0020012020 on channel 0x0000797f [unknown] SEMAPHORE_BG/PFIFO_READ/00 reason: PAGE_NOT_PRESENT
Comment 6 Pierre Moreau 2015-02-19 10:30:55 UTC
There was some patches specifically for NVAA/AC cards that went into kernel 3.19. They solve a different issue, but it would still be worth to test it - a lot of other patches were merged since 3.13, which might also help with it.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.