Bug 69969 - Xvideo missing for VIA CN700 with KMS
Summary: Xvideo missing for VIA CN700 with KMS
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/openchrome (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Openchrome development list
QA Contact:
Depends on:
Reported: 2013-09-30 15:11 UTC by Octavian Petre
Modified: 2019-09-18 20:48 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

Xorg log file (34.38 KB, text/plain)
2013-09-30 15:13 UTC, Octavian Petre
no flags Details
X log file with NO KMS (27.51 KB, text/plain)
2013-10-07 11:33 UTC, Octavian Petre
no flags Details
Allow digital mon (567 bytes, patch)
2013-10-09 17:58 UTC, Xavier Bachelot
no flags Details | Splinter Review

Description Octavian Petre 2013-09-30 15:11:51 UTC
X-Video Extension version 2.2
screen #0
 no adaptors present

I am using KMS as described in 

with x11-drivers/xf86-video-openchrome-0.3.3

How can I enable XVideo?

Best regards,

P.S. have also attached the Xorg.0.log
Comment 1 Octavian Petre 2013-09-30 15:13:00 UTC
Created attachment 86854 [details]
Xorg log file
Comment 2 Octavian Petre 2013-10-04 19:50:30 UTC
No activity, so let me add more information why I've tried KMS.

Without KMS one of my monitors (actually a TV with VGA input) does not get detected, thus when X starts I get a blank screen. With other monitors it works OK and I get XVideo.

With KMS, the monitor gets detected, but the Xvideo is not available. 

Any idea on how to get XVideo and the monitor being detected? I do not need something else since this would be a mythtv box. 

Thank you in advance for any suggestions,
Comment 3 Xavier Bachelot 2013-10-06 20:22:43 UTC
KMS is still a work in progress, there's no acceleration, including Xv, with it yet.

About the VGA issue, please provide the X log with the driver using UMS and a regular kernel (not drm-openchrome kernel).
Comment 4 Octavian Petre 2013-10-07 11:33:43 UTC
Created attachment 87233 [details]
X log file with NO KMS

As requested the X org log file without KMS.
Comment 5 Xavier Bachelot 2013-10-08 15:21:13 UTC
Ok, so the EDID probing works with KMS, but not with UMS. You can probably workaround the issue by passing a modeline to the X server, but anyway, it would be nice to understand and fix the bug.
What are the board brand and model and what's the setup ? I read it as VGA connector on the board to VGA input on the TV, but it might as well be DVI-A on the board to VGA on the TV.
Comment 6 Octavian Petre 2013-10-08 16:00:29 UTC
As far as I remember I did you pass a modeline in the xorg.conf file
without success. It looks like VGA is still not activated.

I also agree that we should understand what is the issue. The board is a
Via EPIA 12000 eden (fanless).

Board has a VGA output and the TV a DVI-A (and D together)

It should also mention that with a monitor with VGA input,  thus a pure VGA
cable,  it works.
Comment 7 Octavian Petre 2013-10-08 16:57:56 UTC
Could not find the VIA site anymore. :-(
Comment 8 Xavier Bachelot 2013-10-09 17:58:03 UTC
Created attachment 87350 [details] [review]
Allow digital mon

Does this patch help ? (this is against git master)
Comment 9 Octavian Petre 2013-10-09 17:59:23 UTC
I will try it tomorrow
On Oct 9, 2013 8:58 PM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 8 <https://bugs.freedesktop.org/show_bug.cgi?id=69969#c8> on bug
> 69969 <https://bugs.freedesktop.org/show_bug.cgi?id=69969> from Xavier
> Bachelot <xavier@bachelot.org> *
> Created attachment 87350 [details] [review] <https://bugs.freedesktop.org/attachment.cgi?id=87350> [details] <https://bugs.freedesktop.org/attachment.cgi?id=87350&action=edit> [review] <https://bugs.freedesktop.org/page.cgi?id=splinter.html&bug=69969&attachment=87350>
> Allow digital mon
> Does this patch help ? (this is against git master)
>  ------------------------------
> You are receiving this mail because:
>    - You are on the CC list for the bug.
>    - You reported the bug.
Comment 10 Octavian Petre 2013-10-13 10:08:41 UTC
(In reply to comment #8)
> Created attachment 87350 [details] [review] [review]
> Allow digital mon
> Does this patch help ? (this is against git master)

Yes, TV gets detected. Note that I am not using any xorg.conf file.
Thank you for your fast fix.

Best regards,

P.S. Trying to force some modes via xorg.conf made the driver/x server crash. Still need to investigate more since I have a lot of other options active. I need to provide my modes since the TV does not provide the exact matrix size.
Comment 11 GitLab Migration User 2019-09-18 20:48:41 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/openchrome/old-bug-database/issues/12.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.