Bug 70042 - Major texture flickering in Dota 2 (r600g on HD 6950)
Major texture flickering in Dota 2 (r600g on HD 6950)
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/Radeon
XOrg git
All All
: medium normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 16:24 UTC by Alexandre Demers
Modified: 2013-10-06 20:56 UTC (History)
1 user (show)

See Also:


Attachments
Visible corruption on mini-map (278.36 KB, image/jpeg)
2013-10-03 06:14 UTC, Alexandre Demers
no flags Details
Many glitches in the middle of the screen (311.37 KB, text/plain)
2013-10-03 06:16 UTC, Alexandre Demers
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Demers 2013-10-02 16:24:31 UTC
Using a HD 6950 on Arch Linux 64
Using git codes for drm, mesa and ddx.

The game suffers from a major texture flickering in Dota 2. It has been since the release of the game. I'll attach an API Trace later today and some screenshots. It could be related to bug 68451, but the flickering is a lot more important than the screenshots seem to indicate.

I could also test by disabling shaders's sb optimization.
Comment 1 Alexandre Demers 2013-10-03 01:11:44 UTC
We can cross off the board:
sb optimization
Comment 2 Alexandre Demers 2013-10-03 05:59:59 UTC
I can't seem to be able to launch dota 2 with apitrace. I can launch Steam, but Dota keeps crashing at launch. I'll add screenshots later.
Comment 3 Alexandre Demers 2013-10-03 06:14:49 UTC
Created attachment 87012 [details]
Visible corruption on mini-map

While the texture flickering is very fast, it appears as static on screenshots. On this one, textures flickering on the mini-map and a thin artifact on the left side of the screen (looks like a line, but it is most likely a triangle caused by the light coming from a tower)
Comment 4 Alexandre Demers 2013-10-03 06:16:46 UTC
Created attachment 87013 [details]
Many glitches in the middle of the screen

Here, some more visible glitches flickering at an impressive pace.
Comment 5 Alexandre Demers 2013-10-05 04:46:13 UTC
Here is a link to a video exhibiting the corruptions/glitches.
https://docs.google.com/file/d/0Bw_tZdWsNa4BN0ZmRy1DMnFKZWs/edit?usp=sharing

You'll notice glitches here and there, mostly triangles. On the minimap, on the player's face and on some elements (name or HP), it is really visible. Working on an api trace (I have a trace, working on trimming it down).
Comment 6 Alexandre Demers 2013-10-05 23:37:17 UTC
attachment 87165 [details] [review] seems to fix the flickering
Comment 7 Alexandre Demers 2013-10-05 23:38:42 UTC
Marek, should I continue with the API trace if the patch fixes the flickering?
Comment 8 Marek Olšák 2013-10-06 01:07:00 UTC
No, I'll commit the patch.
Comment 9 Alexandre Demers 2013-10-06 20:56:06 UTC
I don't know the impact on performance of attachment 87165 [details] [review]. Dota 2 was the only game I was experiencing this texture flickering. It would be interesting to understand what and why. Anyway, it fixes the issue, so closing this bug.