Bug 7019 - Machine hangs in 24-bit non-DRI mode
Summary: Machine hangs in 24-bit non-DRI mode
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.0.0
Hardware: x86 (IA32) Linux (All)
: high critical
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
Depends on:
Reported: 2006-05-24 08:21 UTC by Orion Poplawski
Modified: 2008-12-02 23:32 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

xorg.conf (2.74 KB, text/plain)
2006-05-24 08:22 UTC, Orion Poplawski
no flags Details
Xorg.0.log from crashed server (58.10 KB, text/plain)
2006-05-24 08:23 UTC, Orion Poplawski
no flags Details
X log from crash (56.84 KB, text/plain)
2006-09-11 12:38 UTC, Orion Poplawski
no flags Details

Description Orion Poplawski 2006-05-24 08:21:40 UTC
This is Fedora Core 5 with the xorg-x11-drv-ati- update from
updates-testing.  Machine work fine with the stock driver from FC5.

Driver works okay when running with 16-bit color, which allows DRI to be
enabled.  However, if I specify 24-bit color, there is not enough video memory
and DRI is disabled.  This is expected and I have run this way for years.  With
the new driver though, the machine will lockup completely after a couple minutes.

xorg.conf and Xorg.0.log to be attached.
Comment 1 Orion Poplawski 2006-05-24 08:22:33 UTC
Created attachment 5730 [details]

This has depth set to 16 so I can run.	Set it to 24 and it hangs.
Comment 2 Orion Poplawski 2006-05-24 08:23:17 UTC
Created attachment 5731 [details]
Xorg.0.log from crashed server
Comment 3 Andrew D. Stadler 2006-06-19 14:39:57 UTC
I too am experiencing similar hangs and crashes.  I am using FC5 on a T30 thinkpad (radeon mobility 
7500).  In my case, any dual-head configuration - 24bpp or 16bpp - experiences random and complete 
hangs (hard reset required).
Comment 4 Orion Poplawski 2006-07-27 09:58:23 UTC
With latest FC5 kernels, this locks up it both 24-bit non-DRI and 16-bit/DRI
modes for me.  Anything I can do to debug?
Comment 5 Orion Poplawski 2006-09-11 12:38:35 UTC
Created attachment 6913 [details]
X log from crash

Another machine that this hangs, IBM ThinkPad T42 with:

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
Comment 6 Roland Roberts 2006-09-23 07:18:26 UTC
This is little more than a "me-too" report.  My Thinkpad T30 hangs randomly in
DRI or non-DRI mode, although it *seems* to hang more frequently in DRI mode. 
16-bit vs 24-bit seems to make no difference.  It may be anywhere from minutes
to days between lockups (but recently it's been several times a day).
Comment 7 Michel Dänzer 2006-09-25 00:32:57 UTC
If you haven't tried current xf86-video-ati git yet, please do.
Comment 8 Orion Poplawski 2006-10-06 10:24:40 UTC
(In reply to comment #7)
> If you haven't tried current xf86-video-ati git yet, please do.

Does it work with Xorg 1.0.1?  Looks like newer versions require 1.1.X and I'm
stuck at 1.0.1 for now.
Comment 9 Orion Poplawski 2006-10-06 12:43:29 UTC
In trying to compile 6.6.3 against 1.0.1, I get:

gcc -DHAVE_CONFIG_H -I. -I. -I.. -DXFree86Server -DIN_MODULE -DXFree86Module
-DXFree86LOADER -I/usr/include/xorg -I/usr/include/drm -I/usr/include/X11/dri
-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -MT aticonfig.lo -MD -MP -MF .deps/aticonfig.Tpo -c
aticonfig.c  -fPIC -DPIC -o .libs/aticonfig.o
aticonfig.c: In function 'ATIProcessOptions':
aticonfig.c:365: error: 'struct _ATIRec' has no member named 'RenderAccelEnabled'

It appears that aticonfig.c and atistruct.h seem to have different opinions
about whether RenderAccelEnabled belongs in _ATIRec if USE_EXA is not defined.

This patch assumes that atistruct.h has is right:

--- xf86-video-ati-6.6.3/src/aticonfig.c.exa    2006-10-03 08:49:13.000000000 -0600
+++ xf86-video-ati-6.6.3/src/aticonfig.c        2006-10-06 13:29:33.000000000 -0600
@@ -362,8 +362,8 @@
             "Using %s acceleration architecture\n",
             pATI->useEXA ? "EXA" : "XAA");

-        pATI->RenderAccelEnabled = FALSE;
 #if defined(USE_EXA)
+        pATI->RenderAccelEnabled = FALSE;
         if (pATI->useEXA && RenderAccel)
             pATI->RenderAccelEnabled = TRUE;
Comment 10 Michel Dänzer 2006-10-08 13:48:33 UTC
You don't need to build the atimisc driver. Try

make -C src/ {ati,radeon}_drv.la

Or try ati-1-0-branch for X.Org 7.0, it should also have the critical fixes.
Comment 11 Orion Poplawski 2006-10-15 19:39:43 UTC and 2.6.18-1.2189.fc5 works in 16 bit/DRI mode but seems to hang in
24-bit/non-DRI mode on my Inspiron 4150 (Radeon Mobility M7 LW).
Comment 12 Orion Poplawski 2006-11-03 10:11:50 UTC
Just experienced with FC6 in 24-bit/non-DRI mode:


shifting back to 16-bit/DRI...
Comment 13 Orion Poplawski 2006-11-28 15:56:13 UTC
Still happening with 24-bit/non-DRI and kernel-2.6.18-1.2849.fc6.  16-bit/DRI is
pretty stable at the moment.  Still xorg-x11-drv-ati-6.6.2-4.fc6.
Comment 14 Daniel Stone 2007-02-27 01:32:10 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 15 Alex Deucher 2007-08-31 07:38:35 UTC
Can anyone still reproduce this?
Comment 16 Alex Deucher 2008-12-02 23:32:12 UTC
no feedback for over a year.  closing.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.