Bug 704 - Should MACCESS be validated?
Summary: Should MACCESS be validated?
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/other (show other bugs)
Version: DRI git
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-01 08:01 UTC by Adam Jackson
Modified: 2019-10-14 13:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Jackson 2004-06-01 08:01:40 UTC
originally
http://sourceforge.net/tracker/index.php?func=detail&aid=216018&group_id=387&atid=100387

In mga_drm.h comments indicate that only DSTORG and TEXORG is validated.
I think bit 15 (memreset) of MACCESS should be checked as
well:

"The memreset field must always be set to '0' except under specific conditions
which occur during the reset sequence."

Seems like something which should not be accessible to normal users.
Comment 1 chemtech 2013-03-15 08:07:10 UTC
ajax at nwnk dot net,
Do you still experience this issue with newer soft?
Please check the status of your issue.
Comment 2 Martin Peres 2019-10-14 13:20:20 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.