Bug 70569 - DOTA2 background and other missing elements on HD4850 GPU
Summary: DOTA2 background and other missing elements on HD4850 GPU
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-17 09:49 UTC by Roc Vallès Domènech
Modified: 2014-05-12 05:12 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Screenshot of the fountain on a newly started game (1.30 MB, image/png)
2013-10-17 09:49 UTC, Roc Vallès Domènech
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roc Vallès Domènech 2013-10-17 09:49:03 UTC
Created attachment 87786 [details]
Screenshot of the fountain on a newly started game

On a HD4850, DOTA2 in-game background and some other objects aren't being rendered. Attached screenshot shows the problem well.

DOTA2 graphics settings are at the lowest (didn't help). This is using git mesa3d on a current (~amd64) Gentoo, built both with and without LLVM shader compiler backend. Kernel is 3.12-rc5.

It has, to my knowledge, never worked... I kept trying it once in a while for half a year.

Since nobody else has complained yet, I suspect it's a problem that affects only the HD4xxx line of cards.
Comment 1 Roc Vallès Domènech 2013-10-17 09:51:21 UTC
Comment on attachment 87786 [details]
Screenshot of the fountain on a newly started game

Made it png image mime. (Or trying to)
Comment 2 Roc Vallès Domènech 2014-05-12 05:12:32 UTC
Fixed by not using LLVM, which is the case as of Mesa 10.1.2.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.