Bug 70660 - ATI R6xx HDMI Audio only works with 44.1KHz
Summary: ATI R6xx HDMI Audio only works with 44.1KHz
Status: RESOLVED DUPLICATE of bug 69675
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.7 (2012.06)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-20 03:41 UTC by Tom Yan
Modified: 2013-10-26 20:12 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Yan 2013-10-20 03:41:49 UTC
I am using an Evergreen (HD5850).

Actually I also seem to be able to have sound when the sampling rate is mutiples of 44.1KHz(22.05, 88.2, 176.4), but not 48KHz(96, 192). 32Khz doesn't seem to work too. The reason I use "seem" is because I am not sure if there is any software resampling done for those multiples.

And I have tested this in mutiple environment: Pulse, pure ALSA, jack, the result is all the same. So I am quite certain that it's not some issue caused by setting (at least not a "high level" one).

But is the open source driver suppose to work with 48/96/192KHz yet?

https://bbs.archlinux.org/viewtopic.php?pid=1339301
https://bbs.archlinux.org/viewtopic.php?id=157351
FYR, some of my observation that MIGHT help. (How stupid I am to make duplicate like this.)

P.S. I've also tested with hwac3 in mplayer. 48KHz is also silent, while 44.1KHz AC3 can produce some sort of (loud) "clicking noise". Btw is AC3 passthrough suppose to work yet?
Comment 1 Tom Yan 2013-10-26 20:12:27 UTC

*** This bug has been marked as a duplicate of bug 69675 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.