Bug 70662 - Add new keymap for Manipuri language using Meetei mayek script
Summary: Add new keymap for Manipuri language using Meetei mayek script
Status: RESOLVED FIXED
Alias: None
Product: xkeyboard-config
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: highest enhancement
Assignee: xkb
QA Contact:
URL:
Whiteboard:
Keywords: l10n
Depends on:
Blocks:
 
Reported: 2013-10-20 06:09 UTC by Santosh Heigrujam
Modified: 2014-01-18 05:48 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
diffs for affected files in rules and symbols directory (1.30 KB, text/plain)
2013-10-20 06:09 UTC, Santosh Heigrujam
Details
attachment-16790-0.html (1.56 KB, text/html)
2013-12-22 04:46 UTC, Santosh Heigrujam
Details
attachment-16790-1.dat (1 bytes, text/plain)
2013-12-22 04:46 UTC, Santosh Heigrujam
Details
eeyek.patch (3.79 KB, text/x-patch)
2013-12-22 04:46 UTC, Santosh Heigrujam
Details
attachment-23906-0.html (1.72 KB, text/html)
2013-12-24 09:32 UTC, Santosh Heigrujam
Details
attachment-23906-1.dat (1 bytes, multipart/alternative)
2013-12-24 09:32 UTC, Santosh Heigrujam
Details
base.xml.in.eeyek.patch (993 bytes, text/x-patch)
2013-12-24 09:32 UTC, Santosh Heigrujam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Santosh Heigrujam 2013-10-20 06:09:17 UTC
Created attachment 87863 [details]
diffs for affected files in rules and symbols directory

Overview:
This is to add the keymap for Manipuri language using Meetei mayek script. It is included as a variant in "in" layout as "Manipuri (Eeyek)". The necessaray files in rules directory has been modified. The symbols file "in" has also been modified to include the new keymap.

Steps to reproduce:
1. Open System settings in Ubuntu
2. Go to Keyboard -> Typing -> Layout settings
3. Try to add input source by searching for Manipuri

Actual results:
Input source not present

Platform:
Ubuntu 13.10
Fedora 19
Comment 1 Ran Benita 2013-10-20 07:33:35 UTC
Reassigning to xkeyboard-config.
Btw: it's better to submit a patch generated by git rather than a gzipped one (just do `git format-patch` after committing your changes); this way it's possible to look at it directly from the bug, and easier to apply.
Comment 2 Santosh Heigrujam 2013-10-20 10:58:08 UTC
I'll do that an report back again. Thanks for the help.


On Sun, Oct 20, 2013 at 1:03 PM, <bugzilla-daemon@freedesktop.org> wrote:

>  Ran Benita <ran234@gmail.com> changed bug 70662<https://bugs.freedesktop.org/show_bug.cgi?id=70662>
>  What Removed Added  Assignee daniel@fooishbar.org xkb@listserv.bat.ru  QA
> Contact ran234@gmail.com     Product libxkbcommon xkeyboard-config
> Component General General
>
>  *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=70662#c1> on bug
> 70662 <https://bugs.freedesktop.org/show_bug.cgi?id=70662> from Ran Benita<ran234@gmail.com>
> *
>
> Reassigning to xkeyboard-config.
> Btw: it's better to submit a patch generated by git rather than a gzipped one
> (just do `git format-patch` after committing your changes); this way it's
> possible to look at it directly from the bug, and easier to apply.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 3 Sergey V. Udaltsov 2013-10-28 01:20:00 UTC
Looking forward to getting proper patch. Thank you!
Comment 4 Santosh Heigrujam 2013-11-01 13:20:10 UTC
I have been unable to clone the repository at

git://anongit.freedesktop.org/git/xkeyboard-config

I get the following errors while trying to clone the repository:

Cloning into 'xkeyboard-config'...
fatal: unable to connect to anongit.freedesktop.org:
anongit.freedesktop.org[0: 131.252.210.161]: errno=Connection refused


Please help me out.


On Mon, Oct 28, 2013 at 6:50 AM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 3 <https://bugs.freedesktop.org/show_bug.cgi?id=70662#c3> on bug
> 70662 <https://bugs.freedesktop.org/show_bug.cgi?id=70662> from Sergey V.
> Udaltsov <svu@gnome.org> *
>
> Looking forward to getting proper patch. Thank you!
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 5 James Cloos 2013-11-04 22:04:37 UTC
> git://anongit.freedesktop.org/git/xkeyboard-config

> I get the following errors while trying to clone the repository:

> Cloning into 'xkeyboard-config'...
> fatal: unable to connect to anongit.freedesktop.org:
> anongit.freedesktop.org[0: 131.252.210.161]: errno=Connection refused

Try using http://, then, instead of git:// :

git clone http://anongit.freedesktop.org/git/xkeyboard-config

I just confirmed that both URIs are clonable.
Comment 6 Santosh Heigrujam 2013-11-05 01:24:12 UTC
Thanks a lot.
Now I have cloned the repository using http://.
I will work and report back.


On Tue, Nov 5, 2013 at 3:34 AM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 5 <https://bugs.freedesktop.org/show_bug.cgi?id=70662#c5> on
> bug 70662 <https://bugs.freedesktop.org/show_bug.cgi?id=70662> from James
> Cloos <cloos@jhcloos.com> *
>
> > git://anongit.freedesktop.org/git/xkeyboard-config
> > I get the following errors while trying to clone the repository:
> > Cloning into 'xkeyboard-config'...
> > fatal: unable to connect to anongit.freedesktop.org:
> > anongit.freedesktop.org[0: 131.252.210.161]: errno=Connection refused
>
>
> Try using http://, then, instead of git:// :
>
> git clone http://anongit.freedesktop.org/git/xkeyboard-config
>
> I just confirmed that both URIs are clonable.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 7 Santosh Heigrujam 2013-12-04 05:01:32 UTC
How do I push back my changes to the master branch?
When I do:

git push

I got the following message:

fatal: unable to access '
http://anongit.freedesktop.org/git/xkeyboard-config/': The requested URL
returned error: 403

Please help.
Thanks.


On Tue, Nov 5, 2013 at 6:54 AM, Santosh Heigrujam
<santosh.tomba@gmail.com>wrote:

> Thanks a lot.
> Now I have cloned the repository using http://.
> I will work and report back.
>
>
> On Tue, Nov 5, 2013 at 3:34 AM, <bugzilla-daemon@freedesktop.org> wrote:
>
>>   *Comment # 5 <https://bugs.freedesktop.org/show_bug.cgi?id=70662#c5>
>> on bug 70662 <https://bugs.freedesktop.org/show_bug.cgi?id=70662> from
>> James Cloos <cloos@jhcloos.com> *
>>
>> > git://anongit.freedesktop.org/git/xkeyboard-config
>> > I get the following errors while trying to clone the repository:
>> > Cloning into 'xkeyboard-config'...
>> > fatal: unable to connect to anongit.freedesktop.org:
>> > anongit.freedesktop.org[0: 131.252.210.161]: errno=Connection refused
>>
>>
>> Try using http://, then, instead of git:// :
>>
>> git clone http://anongit.freedesktop.org/git/xkeyboard-config
>>
>> I just confirmed that both URIs are clonable.
>>
>>  ------------------------------
>> You are receiving this mail because:
>>
>>    - You reported the bug.
>>
>>
>
Comment 8 Sergey V. Udaltsov 2013-12-18 21:58:59 UTC
You cannot push changes to the repo, you are in readonly mode in relation to the main git source.

Could you please attach the patch for all affected files? Not a set of diffs... Or even better - git-format-patch
Comment 9 Santosh Heigrujam 2013-12-22 04:46:10 UTC
Created attachment 91110 [details]
attachment-16790-0.html

Thanks for helping me out.
I did a git-format-patch for 2 commits. I have attached the patch.
Please check it.


On Thu, Dec 19, 2013 at 3:28 AM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 8 <https://bugs.freedesktop.org/show_bug.cgi?id=70662#c8> on
> bug 70662 <https://bugs.freedesktop.org/show_bug.cgi?id=70662> from Sergey
> V. Udaltsov <svu@gnome.org> *
>
> You cannot push changes to the repo, you are in readonly mode in relation to
> the main git source.
>
> Could you please attach the patch for all affected files? Not a set of diffs...
> Or even better - git-format-patch
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 10 Santosh Heigrujam 2013-12-22 04:46:10 UTC
Created attachment 91111 [details]
attachment-16790-1.dat
Comment 11 Santosh Heigrujam 2013-12-22 04:46:10 UTC
Created attachment 91112 [details]
eeyek.patch
Comment 12 Sergey V. Udaltsov 2013-12-23 23:35:21 UTC
The first patch is empty, for some reason.
The 2nd patch contains 2 parts:
- extra codes for Norwegian languages(irrelevant for the current bug report)
- the actual Manipuri variant.

Regarding the 2nd one, could you please make sure base.xml.in is patched with new variant?
Comment 13 Santosh Heigrujam 2013-12-24 09:32:22 UTC
Created attachment 91173 [details]
attachment-23906-0.html

I have patched base.xml.in to include the Manipuri variant.
The patch file attached in this email. Please check it.
Thanks.


On Tue, Dec 24, 2013 at 5:05 AM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 12 <https://bugs.freedesktop.org/show_bug.cgi?id=70662#c12>
> on bug 70662 <https://bugs.freedesktop.org/show_bug.cgi?id=70662> from
> Sergey V. Udaltsov <svu@gnome.org> *
>
> The first patch is empty, for some reason.
> The 2nd patch contains 2 parts:
> - extra codes for Norwegian languages(irrelevant for the current bug report)
> - the actual Manipuri variant.
>
> Regarding the 2nd one, could you please make sure base.xml.in is patched with
> new variant?
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 14 Santosh Heigrujam 2013-12-24 09:32:23 UTC
Created attachment 91174 [details]
attachment-23906-1.dat
Comment 15 Santosh Heigrujam 2013-12-24 09:32:23 UTC
Created attachment 91175 [details]
base.xml.in.eeyek.patch
Comment 16 Santosh Heigrujam 2013-12-30 14:06:38 UTC
If the inclusion of the Manipuri variant is successful please inform.
Thanks.


On Tue, Dec 24, 2013 at 3:02 PM, Santosh Heigrujam
<santosh.tomba@gmail.com>wrote:

> I have patched base.xml.in to include the Manipuri variant.
> The patch file attached in this email. Please check it.
> Thanks.
>
>
> On Tue, Dec 24, 2013 at 5:05 AM, <bugzilla-daemon@freedesktop.org> wrote:
>
>>   *Comment # 12 <https://bugs.freedesktop.org/show_bug.cgi?id=70662#c12>
>> on bug 70662 <https://bugs.freedesktop.org/show_bug.cgi?id=70662> from
>> Sergey V. Udaltsov <svu@gnome.org> *
>>
>> The first patch is empty, for some reason.
>> The 2nd patch contains 2 parts:
>> - extra codes for Norwegian languages(irrelevant for the current bug report)
>> - the actual Manipuri variant.
>>
>> Regarding the 2nd one, could you please make sure base.xml.in is patched with
>> new variant?
>>
>>  ------------------------------
>> You are receiving this mail because:
>>
>>    - You reported the bug.
>>
>>
>
Comment 17 Sergey V. Udaltsov 2014-01-15 01:04:44 UTC
committed. please check in git. Next time, could you pls not add empty attachments? Like 91174 or 91111.
Comment 18 Santosh Heigrujam 2014-01-18 05:48:36 UTC
Thanks a lot for the support and great help.
I'll make it sure to not add empty attachments next time.
Thanks again.


On Wed, Jan 15, 2014 at 6:34 AM, <bugzilla-daemon@freedesktop.org> wrote:

>  Sergey V. Udaltsov <svu@gnome.org> changed bug 70662<https://bugs.freedesktop.org/show_bug.cgi?id=70662>
>  What Removed Added  Status NEW RESOLVED  Resolution --- FIXED
>
>  *Comment # 17 <https://bugs.freedesktop.org/show_bug.cgi?id=70662#c17>
> on bug 70662 <https://bugs.freedesktop.org/show_bug.cgi?id=70662> from
> Sergey V. Udaltsov <svu@gnome.org> *
>
> committed. please check in git. Next time, could you pls not add empty
> attachments? Like 91174 or 91111.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.