Bug 70772 - Error with misformatted "pim-manager.ini"
Summary: Error with misformatted "pim-manager.ini"
Status: RESOLVED FIXED
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: PIM Manager (show other bugs)
Version: 1.3.99.3
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: SyncEvolution Community
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-22 17:51 UTC by Eugenio Parodi
Modified: 2013-11-28 16:11 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugenio Parodi 2013-10-22 17:51:41 UTC
A misformatted pim-manager.ini file prevent syncevolution from starting.

I have clean syncevolution settings (removed all files from cache, local and config folders).

Here are the steps to reproduce the problem:
	1)	I’m adding two peers: testpeer1 and testpeer2 - no pim-manager.ini at this time created yet
	2)	I’m synchronizing testpeer1 – still no pim-manager.ini created
	3)	I’m setting testpeer1 as active addressbook - pim-manager.ini was created and contains one line: 
			active = pim-manager-testpeer1
	4)	I’m removing testpeer2  - pim-manager.ini contains two lines: 
			active = pim-manager-testpeer1
			sort = pim-manager-testpeer1
	               With such file syncevolution will not start again.

	4.1)	If instead doing step 4 I will remove testpeer1 pim-manager.ini will contains two lines: 
			active = pim-manager-testpeer1
			sort = 
		In that case syncevolution will restart without problem
Comment 1 Patrick Ohly 2013-10-27 19:22:26 UTC
(In reply to comment #0)
> 	4)	I’m removing testpeer2  - pim-manager.ini contains two lines: 
> 			active = pim-manager-testpeer1
> 			sort = pim-manager-testpeer1

The bug was that "sort" was set instead of "active" in this particular code path (= removing a peer while some address books are active). I've fixed that and added a test case.

That SyncEvolution did not start after that bug broke pim-manager.ini points towards a second problem: how are corrupted files handled? This is essentially undefined at the moment (= we haven't discussed the desired outcome).

However, in this particular case it is clearly undesirable that PIM Manager no longer starts, because the clients have no way of detecting and fixing the problem. It is much better to just ignore the invalid "sort" value and fall back to the default sorting. I've implemented that (again, with with test).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.