Bug 70780 - RFE: Wheel emulation for soft buttons on clickpad and trackpoint
Summary: RFE: Wheel emulation for soft buttons on clickpad and trackpoint
Status: RESOLVED WONTFIX
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/synaptics (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Peter Hutterer
QA Contact:
URL:
Whiteboard:
Keywords:
: 86530 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-22 20:13 UTC by Florian Lorenzen
Modified: 2017-03-09 01:25 UTC (History)
8 users (show)

See Also:
i915 platform:
i915 features:


Attachments
proof patch that allows scrolling with disabled clickpad (709 bytes, patch)
2014-10-03 13:40 UTC, Dmitry Nezhevenko
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Lorenzen 2013-10-22 20:13:54 UTC
I have a Lenovo Helix with a clickpad and a trackpoint that has no buttons of its own. I can configure the soft buttons of the clickpad to provide middle and right buttons for the trackpoint just fine. The problem is that I would like mouse wheel emulation using the middle button. The "Evdev Wheel Emulation" for the trackpoint is enabled but it is not working. I suspect that the trackpoint driver does not see the software generated middle button presses. Actually, I am not sure if this has to be solved in the synaptics driver or somewhere else. If another place is more appropriate please redirect me.
Comment 1 Peter Hutterer 2013-10-22 22:22:27 UTC
There is no good way to solve this in the current implementation. The trackpoint and the touchpads are handled by two different drivers that don't share anything, so unless wheel emulation is moved into the server we can't do much here.

This is unlikely to happen anytime soon though, sorry.
Comment 2 Peter Hutterer 2014-03-12 22:41:01 UTC

*** This bug has been marked as a duplicate of bug 74544 ***
Comment 3 Peter Hutterer 2014-03-12 22:41:55 UTC
whoops, wrong bug, sorry. Comment #1 still stands
Comment 4 Keerthan Jaic 2014-03-26 11:09:15 UTC
There is an evdev package on the AUR which supports this:
https://aur.archlinux.org/packages/xf86-input-evdev-trackpoint/
Comment 5 Ari Malinen 2014-09-16 09:31:27 UTC
Is it possible to get trackpoint wheel emulation to work without systemd/udev? Im using thinkpad E531, mouse driver and smdev.
Comment 6 Peter Hutterer 2014-09-16 22:51:13 UTC
systemd has nothing to do with it. udev is used for device-discovery only. This is a problem of the xorg input module structure alone.
Comment 7 Dmitry Nezhevenko 2014-10-03 13:02:17 UTC
If clickpad is disabled (so it only accepts clicks), could we extend such state to also handle two finger scroll?

It should be much easier to implement. And should be easy to use. Maybe it can be added as new property.

If it's ok I can try to make patch for this.
Comment 8 Dmitry Nezhevenko 2014-10-03 13:40:18 UTC
Created attachment 107261 [details] [review]
proof patch that allows scrolling with disabled clickpad

I'm attaching test patch (against synaptics 1.8.1 in debian) that just allows scrolling using disabled clickpad.

If it's ok, I can create final patch that will add this as configurable feature.

Thanks
Comment 9 Ari Malinen 2014-10-17 07:34:47 UTC
I maintain evdev ebuild for Gentoo that supports wheel emulation for trackpoints with clickpad:
https://github.com/causes-/causelay/blob/master/x11-drivers/xf86-input-evdev-trackpoint/xf86-input-evdev-trackpoint-2.9.0.ebuild
Comment 10 Peter Hutterer 2014-11-24 03:22:37 UTC
*** Bug 86530 has been marked as a duplicate of this bug. ***
Comment 11 Peter Hutterer 2017-03-09 01:25:06 UTC
sorry, this won't be fixed in synaptics which is in maintenance mode. libinput has middle button wheel emulation on the trackpoint by default, I suggest using that now.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.