Bug 70946 - x11-drivers/xf86-video-intel-2.99.905
Summary: x11-drivers/xf86-video-intel-2.99.905
Status: RESOLVED DUPLICATE of bug 70835
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Chris Wilson
QA Contact: Intel GFX Bugs mailing list
Depends on:
Reported: 2013-10-28 07:53 UTC by Fabio Coatti
Modified: 2013-10-28 08:01 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Fabio Coatti 2013-10-28 07:53:24 UTC
Starting from 2.99.905 (903 is fine) xorg crashes when using xf86-video-intel driver.

(EE) Backtrace:
(EE) 0: /usr/bin/X (xorg_backtrace+0x3d) [0x57e80d]
(EE) 1: /usr/bin/X (0x400000+0x182459) [0x582459]
(EE) 2: /lib64/libpthread.so.0 (0x7fb6c6e00000+0x10b20) [0x7fb6c6e10b20]
(EE) 3: /lib64/libc.so.6 (__vsprintf_chk+0x6f) [0x7fb6c5d7271f]
(EE) 4: /lib64/libc.so.6 (__sprintf_chk+0x85) [0x7fb6c5d72695]
(EE) 5: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7fb6c4ca6000+0x58f12) [0x7fb6c4cfef12]
(EE) 6: /usr/bin/X (xf86ProbeOutputModes+0x1db) [0x4ac47b]
(EE) 7: /usr/bin/X (0x400000+0xb56fc) [0x4b56fc]
(EE) 8: /usr/bin/X (RRGetInfo+0x88) [0x4f09b8]
(EE) 9: /usr/bin/X (ProcRRGetScreenInfo+0x92) [0x4f8442]
(EE) 10: /usr/bin/X (0x400000+0x3a78e) [0x43a78e]
(EE) 11: /usr/bin/X (0x400000+0x29f1a) [0x429f1a]
(EE) 12: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7fb6c5c96bf5]
(EE) 13: /usr/bin/X (0x400000+0x2a261) [0x42a261]
(EE) Segmentation fault at address 0x0
Fatal server error:
(EE) Caught signal 11 (Segmentation fault). Server aborting

This happens when starting kde, during session init phase. Interesting enough, it happens only if xorg reads the configuration file, thati is very minimal:

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
        Modeline "1600x1200_56.00"  149.00  1600 1704 1872 2144  1200 1203 1207 1242 -hsync +vsync

(I'm forced to use this file because 60Hz can't be managed by the monitor, stupid hardware bug)

If I remove the xorg.conf completely, the crash does not happen (but of course the monitor blinks and whines like crazy :) )

Distro: Gentoo Linux
kernel 3.11.6 x86_64
gcc 4.8.1
[ 30721.806] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
        HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
        HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
        HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
        HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200

Previous version that worked (that I tried)
2.99.903 2.99.901 2.21.15
Comment 1 Chris Wilson 2013-10-28 08:01:05 UTC

*** This bug has been marked as a duplicate of bug 70835 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.