Bug 71049 - [HSW] Corrupted display on Macbook Pro 11,2 Retina (Intel only, late 2013)
[HSW] Corrupted display on Macbook Pro 11,2 Retina (Intel only, late 2013)
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/Intel
XOrg git
x86-64 (AMD64) Linux (All)
: high critical
Assigned To: Intel GFX Bugs mailing list
Intel GFX Bugs mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 14:03 UTC by Gökçen Eraslan
Modified: 2014-01-14 10:21 UTC (History)
7 users (show)

See Also:
i915 platform:
i915 features:


Attachments
photo describing the error (2.00 MB, image/jpeg)
2013-10-30 14:03 UTC, Gökçen Eraslan
no flags Details
dmesg (204.50 KB, text/plain)
2013-10-30 14:04 UTC, Gökçen Eraslan
no flags Details
lspci (5.74 KB, text/plain)
2013-10-30 14:04 UTC, Gökçen Eraslan
no flags Details
Xorg log (21.63 KB, text/plain)
2013-10-30 14:05 UTC, Gökçen Eraslan
no flags Details
xrandr output (8.31 KB, text/plain)
2013-10-30 14:05 UTC, Gökçen Eraslan
no flags Details
i915opregion (8.00 KB, application/octet-stream)
2013-10-30 14:07 UTC, Gökçen Eraslan
no flags Details
interegsnapshot (2.09 MB, application/octet-stream)
2013-10-30 14:08 UTC, Gökçen Eraslan
no flags Details
dmesg output on linux-drm-intel-nightly-20131031 (198.13 KB, text/plain)
2013-10-31 17:19 UTC, Gökçen Eraslan
no flags Details
Additional screenshot (console) (121.93 KB, image/jpeg)
2013-11-07 02:18 UTC, Joseph Coffland
no flags Details
Additional screenshot (166.84 KB, image/jpeg)
2013-11-07 02:19 UTC, Joseph Coffland
no flags Details
KMS-enabled intel_reg_dumper output (latest libdrm + intel_gpu_tools) (12.93 KB, text/plain)
2013-11-13 21:24 UTC, Gökçen Eraslan
no flags Details
KMS-disabled intel_reg_dumper output (latest libdrm + intel_gpu_tools) (12.94 KB, text/plain)
2013-11-13 21:25 UTC, Gökçen Eraslan
no flags Details
dmesg output (drm.debug=0x06, kernel intel-drm-nightly-20131113) (207.52 KB, text/plain)
2013-11-14 07:05 UTC, Gökçen Eraslan
no flags Details
dmesg output (drm.debug=0x06, kernel=3.12-final) (212.45 KB, text/plain)
2013-11-14 07:06 UTC, Gökçen Eraslan
no flags Details
replicate edp bpp hack for hsw (2.00 KB, patch)
2013-11-16 13:13 UTC, Daniel Vetter
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Gökçen Eraslan 2013-10-30 14:03:44 UTC
Created attachment 88363 [details]
photo describing the error

I'm experiencing a corrupted display on my retina MBP, late 2013, intel-only model. There are greenish vertical lines and also thicker black ones on the right-hand side of the screen. Photo is attached, I'll be attaching also necessary files for debugging.

I am using Ubuntu 13.10, mesa 9.2.1, Xorg 1.14.3 + the latest xorg/driver/xf86-video-intel from git, kernel 3.12rc7.
Comment 1 Gökçen Eraslan 2013-10-30 14:04:14 UTC
Created attachment 88364 [details]
dmesg
Comment 2 Gökçen Eraslan 2013-10-30 14:04:38 UTC
Created attachment 88365 [details]
lspci
Comment 3 Gökçen Eraslan 2013-10-30 14:05:00 UTC
Created attachment 88366 [details]
Xorg log
Comment 4 Gökçen Eraslan 2013-10-30 14:05:23 UTC
Created attachment 88367 [details]
xrandr output
Comment 5 Gökçen Eraslan 2013-10-30 14:07:13 UTC
Created attachment 88368 [details]
i915opregion
Comment 6 Gökçen Eraslan 2013-10-30 14:08:54 UTC
Created attachment 88369 [details]
interegsnapshot
Comment 7 Chris Wilson 2013-10-30 14:09:57 UTC
Does this happen at all resolutions? In particular is the display fine at native resolution?
Comment 8 Gökçen Eraslan 2013-10-30 14:12:17 UTC
I have tried 1440x900 and 2880x1800 and both was the same. By the way, I'm using EFI mode with grub2. Also, plymouth is also garbled.
Comment 9 johan 2013-10-30 21:18:33 UTC
Yes, this happens for all resolutions. I have the same issue with the latest Fedora 20 nightly live cd.
Comment 10 Paulo Zanoni 2013-10-31 16:11:17 UTC
Hi

Can you please try this patch?
https://bugzilla.kernel.org/attachment.cgi?id=111321&action=diff

This sounds like https://bugzilla.kernel.org/show_bug.cgi?id=59841.

Thanks,
Paulo
Comment 11 Gökçen Eraslan 2013-10-31 17:19:30 UTC
Created attachment 88419 [details]
dmesg output on linux-drm-intel-nightly-20131031

I have tried linux-drm-intel-nightly-20131031 package[1] from Ubuntu mainline, which seems to have that patch[2], but problem still exists.

dmesg is attached.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-nightly/current/
[2] http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-nightly/current/CHANGES
Comment 12 Joseph Coffland 2013-11-07 02:18:30 UTC
Created attachment 88803 [details]
Additional screenshot (console)
Comment 13 Joseph Coffland 2013-11-07 02:19:03 UTC
Created attachment 88804 [details]
Additional screenshot
Comment 14 Joseph Coffland 2013-11-07 02:23:36 UTC
Note that https://bugzilla.kernel.org/show_bug.cgi?id=59841 mentions a blank screen.  This bug is about a corrupt screen.

There is something wrong with some of the vertical columns.  Many columns seem to actually be correct but are perhaps out of sync.

This bug may be a kernel or driver level issue because it manifests in both Xorg and on the console once it switches modes on boot up.
Comment 15 Jani Nikula 2013-11-08 11:55:29 UTC
Joseph, regression? Which versions worked?
Comment 16 Harry Rod 2013-11-09 01:55:15 UTC
(In reply to comment #15)
> Joseph, regression? Which versions worked?

Hi, i don't understand why this is marked as regression. I have been unable to ever get this working correctly for me. Those of us over at arch with MBP11,2 have been using nomodeset and xf86-video-fbdev as a temporary solution.

(Those additional screenshots are actually mine.) Is there any info/logs i can provide to help along a solution to this?

I have tried using kernel 3.12rc7 and xf86-video-intel-devel 2.99.905-1, and neither help. I suspect it's something to do with a high bandwidth DP link due to resolution and/or HD5200 iris pro.
Comment 17 Joseph Coffland 2013-11-12 18:57:20 UTC
Paulo Zanoni, I see you are from Intel.  What can we do to help move this along?  Is it possible that an update was made to the OSX driver that has not yet made it into the Open-Source driver?

According to this thread: http://forums.opensuse.org/english/get-technical-help-here/hardware/489145-intel-hd-5200-iris-pro.html, the HD 5200 iris does work in Linux but has some issues.  So the show stopper described here has to do with the specific combination of the HD 5200 and the 15" retina display.
Comment 18 Daniel Vetter 2013-11-13 10:49:02 UTC
Ok, please grab the latest intel-gpu-tools from git at http://cgit.freedesktop.org/xorg/app/intel-gpu-tools/

Then please grab the output of the intel_reg_dumper tool both for the kms driver and with the kms driver disabled (i915.modeset=0) and attach it to this bug report (as individual files).
Comment 19 Gökçen Eraslan 2013-11-13 21:24:31 UTC
Created attachment 89161 [details]
KMS-enabled intel_reg_dumper output (latest libdrm + intel_gpu_tools)

Here you are.
Comment 20 Gökçen Eraslan 2013-11-13 21:25:34 UTC
Created attachment 89162 [details]
KMS-disabled intel_reg_dumper output (latest libdrm + intel_gpu_tools)

and this is intel_reg_dumper output with KMS disabled.
Comment 21 Daniel Vetter 2013-11-13 22:10:56 UTC
This should be fixed with 3.12, specifically

commit c6cd2ee2d59111a07cd9199564c9bdcb2d11e5cf
Author: Jani Nikula <jani.nikula@intel.com>
Date:   Mon Oct 21 10:52:07 2013 +0300

    drm/i915/dp: workaround BIOS eDP bpp clamping issue

-rc7 doesn't have this patch. Thanks for reporting this issue and please reopen in case my analysis is wrong and the bug isn't fixed. In that case please attach a new drm.debug and kms reg dump when running 3.12.
Comment 22 Gökçen Eraslan 2013-11-14 07:03:58 UTC
No, this commit doesn't fix it. In comment #11, I had said I tried this patch which was in intel-drm-nightly-20131031, and to be sure I have tried latest intel-drm-nightly and mainline 3.12, but no luck, still the same. I am attaching drm.debug dmesgs now.
Comment 23 Gökçen Eraslan 2013-11-14 07:05:09 UTC
Created attachment 89175 [details]
dmesg output (drm.debug=0x06, kernel intel-drm-nightly-20131113)
Comment 24 Gökçen Eraslan 2013-11-14 07:06:31 UTC
Created attachment 89176 [details]
dmesg output (drm.debug=0x06, kernel=3.12-final)
Comment 25 Daniel Vetter 2013-11-16 13:07:55 UTC
Oh right, the bugfix in there needs to be replicated for hsw. Sorry for being dense, I'll work on a patch asap.
Comment 26 Daniel Vetter 2013-11-16 13:13:52 UTC
Created attachment 89315 [details] [review]
replicate edp bpp hack for hsw

Please test this patch on latest drm-intel-nightly, thanks.
Comment 27 Gökçen Eraslan 2013-11-17 08:53:13 UTC
(In reply to comment #26)
> Created attachment 89315 [details] [review] [review]
> replicate edp bpp hack for hsw
> 
> Please test this patch on latest drm-intel-nightly, thanks.

Yes, that patch works fine. Thank you very much.
Comment 28 Daniel Vetter 2013-11-19 16:01:15 UTC
commit 1021442098ee9328fdd4d113d63a3a7f2f40c37b
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Mon Nov 18 07:38:16 2013 +0100

    drm/i915: Replicate BIOS eDP bpp clamping hack for hsw
Comment 29 Daniel Vetter 2014-01-14 10:21:12 UTC
*** Bug 73567 has been marked as a duplicate of this bug. ***