Bug 71575 - Long expressions in shaders crash Mesa
Summary: Long expressions in shaders crash Mesa
Status: RESOLVED DUPLICATE of bug 71574
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: 9.1
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-13 13:04 UTC by Kevin Rogovin
Modified: 2013-11-13 13:09 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Fragment shader of program. (2.08 KB, text/plain)
2013-11-13 13:04 UTC, Kevin Rogovin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Rogovin 2013-11-13 13:04:16 UTC
A long expression in a GLSL shader will crash Mesa, the crash occurs after parsing in generating the HIR from the AST.

Attached is a vertex shader with such a long expression (10,000 add terms).

The bug issue is that although such a shader is not to be found in "real" applications, a malicious website can use WebGL to crash Mesa which would likely crash the browser.
Comment 1 Kevin Rogovin 2013-11-13 13:04:35 UTC
Created attachment 89138 [details]
Fragment shader of program.
Comment 2 Kevin Rogovin 2013-11-13 13:09:51 UTC
Pushed "back" at the wrong time and submitted the bug twice, apologies.

*** This bug has been marked as a duplicate of bug 71574 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.