Bug 71689 - Tahiti LE support
Summary: Tahiti LE support
Status: RESOLVED DUPLICATE of bug 60879
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-17 09:07 UTC by Adam Przywecki
Modified: 2016-03-11 14:30 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg output (54.30 KB, text/plain)
2013-11-18 09:58 UTC, Adam Przywecki
no flags Details
Xorg log file (106.93 KB, text/plain)
2013-11-18 09:59 UTC, Adam Przywecki
no flags Details
dmesg output (55.98 KB, text/plain)
2013-11-19 05:02 UTC, Adam Przywecki
no flags Details
Xorg log file (43.10 KB, text/plain)
2013-11-19 05:02 UTC, Adam Przywecki
no flags Details
hack to use single RB (534 bytes, patch)
2013-11-19 15:24 UTC, Alex Deucher
no flags Details | Splinter Review
dmesg output (712.50 KB, text/plain)
2015-09-04 18:01 UTC, Brandon Shirley
no flags Details
Xorg log file (41.50 KB, text/plain)
2015-09-04 18:02 UTC, Brandon Shirley
no flags Details
dmesg on kernel 4.1.6 (173.14 KB, text/plain)
2015-10-12 07:54 UTC, Ben
no flags Details
x.org log using kernel 4.1.6 (30.31 KB, text/plain)
2015-10-12 07:55 UTC, Ben
no flags Details
dmesg from using kernel 4.2.1 (189.00 KB, text/plain)
2015-10-12 07:56 UTC, Ben
no flags Details
x.org log from using kernel 4.2.1 (31.05 KB, text/plain)
2015-10-12 07:56 UTC, Ben
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Przywecki 2013-11-17 09:07:59 UTC
Hello,

The radeon driver does not seem to support Tahiti LE chips (somewhat rare variation). I have the Powercolor Myst 7870 card and cannot get the open source driver to work (tried up-to-date Manjaro and 13.10 ubuntu). The cursor appears with a dark background and then after 5 seconds the display turns off (monitor can't find any input). The catalyst drivers don't even support the card (apparently the lastest beta version does). I'm willing to provide any logs.

Adam
Comment 1 Alex Deucher 2013-11-17 16:06:14 UTC
Please provide your xorg log and dmesg output.
Comment 2 Adam Przywecki 2013-11-18 09:58:58 UTC
Created attachment 89397 [details]
dmesg output
Comment 3 Adam Przywecki 2013-11-18 09:59:27 UTC
Created attachment 89398 [details]
Xorg log file
Comment 4 Adam Przywecki 2013-11-18 10:06:04 UTC
I've attached the dmesg output and log file. Since the system freezes with ati-video driver, I got the files via chroot and a manjaro live usb system with Catalyst drivers.

Xorg.0.log in /var/log was empty, so I've attached the *.old file (possibly created for the Catalyst session I use to actually use the system). During the boot sequence with the free driver is the message "radeon ... invalid ROM contents". I assume that the driver is expecting Pitcairn (the card is 7870) but it's getting Tahiti.

Adam
Comment 5 Alex Deucher 2013-11-18 13:20:20 UTC
(In reply to comment #4)
> I've attached the dmesg output and log file. Since the system freezes with
> ati-video driver, I got the files via chroot and a manjaro live usb system
> with Catalyst drivers.
> 
> Xorg.0.log in /var/log was empty, so I've attached the *.old file (possibly
> created for the Catalyst session I use to actually use the system). During
> the boot sequence with the free driver is the message "radeon ... invalid
> ROM contents". I assume that the driver is expecting Pitcairn (the card is
> 7870) but it's getting Tahiti.

You can ignore the invalid rom contexts, it's due to some restructuring of how the rom is fetched in the pci subsystem.  

Can you attach your dmesg output and Xorg log with KMS enabled?  You can boot to a non-X runlevel or disable acceleration in X if needed.

Section "Device"
    Identifier "Radeon"
    Driver "radeon"
    Option "NoAccel" "true"
EndSection
Comment 6 Adam Przywecki 2013-11-19 04:50:58 UTC
Do you mean "KMS disabled"? I think that KMS is enabled by default.

Adam
Comment 7 Adam Przywecki 2013-11-19 05:02:08 UTC
Created attachment 89440 [details]
dmesg output
Comment 8 Adam Przywecki 2013-11-19 05:02:38 UTC
Created attachment 89441 [details]
Xorg log file
Comment 9 Adam Przywecki 2013-11-19 05:11:30 UTC
Adding the "NoAccel" "true" option allows to X server to load without problems.

Adam
Comment 10 Alex Deucher 2013-11-19 15:24:26 UTC
Created attachment 89475 [details] [review]
hack to use single RB

Does this mesa patch fix the hangs?  I suspect we need to better handle harvest configs in the raster config setup.
Comment 11 Adam Przywecki 2013-11-21 02:47:25 UTC
Xorg still hangs if I don't disable acceleration. I might have improperly done the test though (I'm not a programmer).

1. Downloaded the lastest mesa tarball.
2. Manually applied your patch.
3. Used PKGBUILD file from archlinux to build packages.
4. Installed ati-dri package.

I assume that your patch only touches the ati-dri package files, so did not install other mesa packages that were built.

Adam
Comment 12 Alex Deucher 2014-02-05 22:37:01 UTC
Can you try the patch and instructions on bug 60879?
Comment 13 Brandon Shirley 2015-09-04 17:59:56 UTC
Hi,

I am having the same problem as Adam.  I have a Sapphire HD 7870.
lspci identifies this card as:
 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti LE [Radeon HD 7870 XT]
I am using Arch linux as my distro.

I have never been able to get the open source radeon driver to work with this card.  After boot I am presented with a black screen, and after a few seconds my monitor turns off.  A few seconds later I can hear the fans on the video card speed up a little bit.  If I use the sysrequest function to SIGTERM all processes, I am then presented with the lightdm login screen and X seems to work, but the Xorg log says that acceleration is disabled.
This black screen happens with 10.6.5-1 and with mesa compiled from git (11.1.0_devel.72584.bd6e516-1-x86_64).

This card does work with catalyst driver.

I am attaching a dmesg log and Xorg.0.log.
Comment 14 Brandon Shirley 2015-09-04 18:01:59 UTC
Created attachment 118079 [details]
dmesg output
Comment 15 Brandon Shirley 2015-09-04 18:02:43 UTC
Created attachment 118080 [details]
Xorg log file
Comment 16 shade 2015-09-16 15:43:19 UTC
Same problem here.

Open Source driver does not working. After boot I am presented with a black screen, and after a few seconds my monitor turns off. Exactly like Brandon and Adam.

Catalyst driver works with this card, but is affected by screen tearing and terrible video performance. No matter the player, no matter DE. In ccc under vsync options, if enabled, tearing becomes much more tolerated, but video playback becomes even worse. In addition to that, changing compositors doesn't seem to solve this problem either.
Comment 17 R9 270X 2015-10-09 09:25:40 UTC
Shade, while your issue could look the same, there're many different reasons why blank screen could happen, ranging from DP link training issues up to GPU lockup. So unless you can grind via logs and make definitive conclusion, you do not have reasons to think it the very same problem. And that's why such reports aren't anyhow useful without logs.

N.b. there was many similar lockups on GCNs and most of these have gone with recent MESA + kernel...
Comment 18 Ben 2015-10-12 07:54:05 UTC
Hi, I also have a Powercolor 7870 Myst Edition and I believe my problems is similar to what the other users here are experiencing. I came here after being referred to come here after filing Bug 947056 in Opensuse Bugzilla. Before filing an Opensuse Bugzilla report, I found a reddit user who also experienced the same problems with his Sapphire 7870 XT card on many other distributions. Sapphire and Powercolor are the only manufacturers that produced 7870 XT cards in the American market.

I used the latest kernel Tumbleweed Kernel at the time when creating the logs and I have also tried using the latest upstream kernel when creating the logs.
Comment 19 Ben 2015-10-12 07:54:57 UTC
Created attachment 118831 [details]
dmesg on kernel 4.1.6
Comment 20 Ben 2015-10-12 07:55:25 UTC
Created attachment 118832 [details]
x.org log using kernel 4.1.6
Comment 21 Ben 2015-10-12 07:56:16 UTC
Created attachment 118833 [details]
dmesg from using kernel 4.2.1
Comment 22 Ben 2015-10-12 07:56:48 UTC
Created attachment 118834 [details]
x.org log from using kernel 4.2.1
Comment 23 shade 2016-02-26 08:53:07 UTC
Sadly i think that every one of us who is affected by this bug, we are on our own.
Comment 24 madmalkav 2016-03-10 10:41:23 UTC
Shade, this problem is being treated on bug #60879

*** This bug has been marked as a duplicate of bug 60879 ***
Comment 25 shade 2016-03-11 14:30:25 UTC
Ok madmalkav, i will then keep an eye in that thread with bug 60879.
Thank you.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.