Bug 71792 - software update tool reports "Cannot download packages whilst offline"
Summary: software update tool reports "Cannot download packages whilst offline"
Status: RESOLVED INVALID
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-apt (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-19 14:37 UTC by rpr
Modified: 2014-02-28 13:35 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
output of gpk-update-viewer -v (14.06 KB, text/plain)
2013-11-19 14:37 UTC, rpr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rpr 2013-11-19 14:37:18 UTC
Created attachment 89472 [details]
output of gpk-update-viewer -v

Debian GNU/Linux testing (jessie), gnome-packagekit 3.8.2-4, GNOME 3 GUI.

Steps to reproduce:

(1) Start Software Update tool (/usr/bin/gpk-update-viewer). It shows there are some updates available.

(2) Click "Install updates". It asks for user authentication.

(3) The following error is displayed and no updates installed:
Failed to process request.
Cannot download packages whilst offline

The output of "gpk-update-viewer -v" in in the attachment.

The Internet connection is fine. Also, installation with apt-get update/upgrade/install works fine.

I've found that Bug 30119 has a recent patch regarding this.
Comment 1 rpr 2014-02-24 15:29:33 UTC
After some research I'd say that this is probably caused by two factors:

(1) The patch that fixed Bug 30119. It makes the aptcc backend check the status of network connectivity as reported by NetworkManager.

(2) If there are some network interfaces defined in /etc/network/interfaces the NetworkManager does not manage them by default, as of Debian 6.0. In that case it reports that there are no network connectivity (see https://wiki.debian.org/NetworkManager).

In my case the network interface settings were specified in /etc/network/interfaces.

The issue was solved by putting managed=true in /etc/NetworkManager/NetworkManager.conf so that NetworkManager also handles that interface:

$ cat /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=true

After that Software Update works as expected.

-- rpr.
Comment 2 itemState 2014-02-27 11:06:32 UTC
I have this problem, too. It is pretty surprising for a normal desktop user. Why is the status "resolved invalid"? I have used the software update feature already at least two times. Only today that error appears, so something must have been broken in the last update.

Debian Jessie w/ KDE. Amd64.
Comment 3 rpr 2014-02-28 13:35:12 UTC
I marked this bug as "resolved invalid" because the Software Update actually works as designed: it reports "Cannot download packages whilst offline" because the Network Manager reports that there is no network connectivity.

In my case the Network Manager reported no connectivity because I manually configured the network interface in /etc/network/interfaces which made the Network Manager refuse to handle that network interface until I changed the default option in /etc/NetworkManager/NetworkManager.conf as explained above.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.