Bug 71865 - Dota 2 menus flicker after changing any video option
Summary: Dota 2 menus flicker after changing any video option
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-21 09:11 UTC by Petri Latvala
Modified: 2017-02-10 22:38 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Screenshot (159.91 KB, image/jpeg)
2013-11-21 09:11 UTC, Petri Latvala
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petri Latvala 2013-11-21 09:11:23 UTC
Created attachment 89577 [details]
Screenshot

Screenshot of Dota 2 after changing resolutions attached. The menu "layers" occasionally flicker into view with no apparent (to my eyes) timing, seemingly randomly.

Changing the resolution back to the original does not fix it. Quitting the game and restarting it starts the game properly in the resolution changed into, and everything works properly.

Mesa version is 9.2.2 from Debian Jessie, i386-arch package as Dota 2 is a 32-bit application. The system otherwise is amd64. Gnome3 as window manager. GPU is Intel Iris Pro.
Comment 1 Eric Anholt 2013-11-22 23:29:59 UTC
I've just assumed this is a game bug.  Have you taken an apitrace and replayed it on another driver?
Comment 2 Eero Tamminen 2013-11-28 12:38:32 UTC
Happens also on Ubuntu with latest (couple of week old) Mesa sources.

The issue happens after applying any video option changes, not just resolution (advanced setting changes aren't applied until DotA2 is restarted, this issue happens after changing resolution, vsync etc generic video options).

DOTA2 outputs a long list of extensions that are not supported with Mesa when it starts.  If I would need to guess which of them missing and DOTA2 not handling that correctly could be related to this, maybe GL_NV_fence or GLX_EXT_swap_control_tear.
Comment 3 Kenneth Graunke 2013-11-28 18:21:29 UTC
AMD doesn't support NV_fence either, and GLX_swap_control_tear shouldn't be necessary.

I second Eric's comment: it'd be great to try this on non-Mesa drivers.
Comment 4 Ian Romanick 2014-01-22 01:39:34 UTC
Does this occur on Mesa 10.0 or git?
Comment 5 Eero Tamminen 2014-02-20 15:53:13 UTC
(In reply to comment #4)
> Does this occur on Mesa 10.0 or git?

It happens also with yesterday's git master version of Mesa.

I'll send you apitrace of the issue privately (it's few hundred MBs).  With Mesa Intel driver trace flickers, with Nvidia proprietary driver it would seem to work fine (is there some way to slow down trace replay on faster cards?).

Apitrace on Nvidia complains about memory waste: texture 15 has mipmaps, while its min filter is inconsistent with mipmaps.

With i965 Mesa driver it complains about invalid operation in glBindFrameBuffer(buffer), and a bit about GPU stalls on mapping busy object.
Comment 6 shuo.wang 2014-11-28 02:14:06 UTC
This bug is also exist on Mesa10.4RC1
Comment 7 fangxun 2014-12-25 09:14:24 UTC
This issue is still exist on mesa-10.4.0.
Comment 8 Alejandro Piñeiro (freenode IRC: apinheiro) 2015-03-13 12:39:43 UTC
(In reply to fangxun from comment #7)
> This issue is still exist on mesa-10.4.0.

I was not able to reproduce this bug with mesa-10.3.2. But in my case I have a haswell GPU.
Comment 9 Eero Tamminen 2016-08-31 09:59:02 UTC
Petri, could you mark this as fixed if you cannot reproduce it anymore with recent Mesa / Dota version?
Comment 10 Matt Turner 2016-11-02 07:05:33 UTC
(In reply to Eero Tamminen from comment #9)
> Petri, could you mark this as fixed if you cannot reproduce it anymore with
> recent Mesa / Dota version?

Let's do this the opposite way. NEEDINFO until the reporter can confirm and reopen.
Comment 11 Annie 2017-02-10 22:38:29 UTC
Dear Reporter,

This Mesa bug has been in the "NEEDINFO" status for over 60 days. I am closing this bug based on lack of response but feel free to reopen if resolution is still needed. Please ensure you're supplying the correct information as requested.

Thank you.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.