Bug 7189 - Kernel hang on ACPI resume if X has been loaded (even after stopping X, and unloading the modules). Radeon 7000
Kernel hang on ACPI resume if X has been loaded (even after stopping X, and u...
Status: RESOLVED INVALID
Product: DRI
Classification: Unclassified
Component: General
XOrg 6.7.0
x86 (IA32) Linux (All)
: high major
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-11 18:44 UTC by Richard Neill
Modified: 2007-04-25 09:58 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Neill 2006-06-11 18:44:24 UTC
Here is a weird bug - not sure whether it is a kernel bug or an X bug. It really
should be filed under Xorg 6.9.0, but this isn't listed as an option above.
Basically, starting X, then stopping it, then doing an ACPI suspend fails to
resume, IFF X has loaded drm.

Here is the most useful set of experiments:


TEST 1)

Boot up with "linux single". Very few modules are loaded.
echo 3 > /proc/acpi/sleep.
It sleeps (and resumes) happily, and repeatedly.

TEST 2)

Restart, to avoid bias. Again, boot up with "linux single".
modprobe drm; modprobe radeon
echo 3 > /proc/acpi/sleep.
It sleeps (and resumes) happily, and repeatedly.


TEST 3)

linux single
modprobe drm; modprobe radeon
startx
STOP x
[drm and radeon modules are automatically removed when X shuts down]
echo 3 > /proc/acpi/sleep
Result: it suspends fine, but will not wake up!
Pressing Fn-F4 spins up the HDD and CPU fan, but nothing else.


TEST 4)

Running X, but without the "Load dri" line is fine.

Test 5)

Running X, with "load dri", AND with Mesa installed is fine.

My conclusion is that something in Xorg does something to the graphics card
which interferes with resume.

Versions:
 Xorg: 6.9.0
 Kernel: 2.6.12, or 2.6.16.20
 Hardware: IBM Thinkpad X22, Rage 7000 card. (radeon driver)

This does not happen with a Thinkpad A22p, with similar (Rage128) hardware.
Comment 1 Erik Andren 2006-07-28 08:55:58 UTC
Is this still an issue with xorg 7.1?
Comment 2 Richard Neill 2006-07-29 10:19:36 UTC
I should think it still applies. However, the affected machine has now been sent
to it's new owner, (with suspend disabled), and so I am afraid I can't test
anything for you.

Incidentally, if I did still have the machine, would there be anywhere to
download a tarball of the latest build, already compiled, and ready to simply
run from a USB-key? If such a thing existed, I think many people would be much
more willing to act on "Is this still present in the latest version" requests,
since it would reduce their time-requirement from 2 hours to 5 minutes.
Comment 3 Tormod Volden 2007-04-25 09:58:46 UTC
Until we get the "Latest-git live CD" (yeay), the latest Ubuntu live-cds are probably a good choice since they are pretty up to date, Xorg and kernel-wise.

If you cannot reproduce the bug any longer, we might as well close this bug. Please reopen if you don't agree.