Bug 72230 - Unable to extract MesaLib-10.0.0.tar.{gz,bz2} with bsdtar
Summary: Unable to extract MesaLib-10.0.0.tar.{gz,bz2} with bsdtar
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium major
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-02 15:55 UTC by Patrick Steinhardt
Modified: 2013-12-04 22:02 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
include only one copy of VERSION in tarball (889 bytes, patch)
2013-12-02 19:50 UTC, Emil Velikov
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Steinhardt 2013-12-02 15:55:44 UTC
It is currently not possible to extract the archive provided on [1] with bsdtar due to duplicated files in the archive. This could be caused by misuse of the -T or -I flags on archive creation probably resulting in corrupted archives (see [2]). GNU tar provides some logic that handles such corruptions and as a result doesn't fail extracting the archive.

[1]: ftp://ftp.freedesktop.org/pub/mesa/10.0/
[2]: https://groups.google.com/forum/#!topic/libarchive-discuss/M86idLujRgw
Comment 1 Emil Velikov 2013-12-02 19:50:01 UTC
Created attachment 90116 [details] [review]
include only one copy of VERSION in tarball

Seems like adding VERSION to EXTRA_FILES was an overkill.

Can you guys confirm that the patch fixes the problem? It seems to work fine here.

Note: you'll have to re-generate the tarballs with "make tarballs"
Comment 2 Patrick Steinhardt 2013-12-02 20:04:43 UTC
I can confirm the attached patch fixes the problem. Thanks.
Comment 3 Emil Velikov 2013-12-03 21:46:07 UTC
Thanks, Patrick. Fix committed.

commit 507c2356e3caa3b7da98787ae2de96c7bca0089e
Author: Emil Velikov <emil.l.velikov@gmail.com>
Date:   Mon Dec 2 19:42:51 2013 +0000

    automake: include only one copy VERSION in tarball

    The VERSION file is tracked by git (git ls-files), thus
    adding it to EXTRA_FILES will result in a duplicate copy
    within the final tarball.
Comment 4 Patrick Steinhardt 2013-12-03 21:50:06 UTC
Would it be possible to provide updated tarballs including this fix?
Comment 5 Matt Turner 2013-12-04 21:15:01 UTC
(In reply to comment #4)
> Would it be possible to provide updated tarballs including this fix?

Doesn't seem worth it.
Comment 6 Ian Romanick 2013-12-04 22:02:57 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Would it be possible to provide updated tarballs including this fix?
> 
> Doesn't seem worth it.

...because 10.0.1 will be along shortly.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.