Bug 7233 - OpenGL unusably slow due to missing IRQs on i945
OpenGL unusably slow due to missing IRQs on i945
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: libGL
XOrg git
x86 (IA32) Linux (All)
: medium normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 15:10 UTC by Norbert Preining
Modified: 2006-08-18 01:50 UTC (History)
1 user (show)

See Also:


Attachments
Check Pipe B for IRQ's (1.06 KB, patch)
2006-06-15 00:12 UTC, Alan Hourihane
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Norbert Preining 2006-06-14 15:10:29 UTC
Hi all!
I am running:
Debian/unstable with libgl1-mesa-dri from experimental, ie 6.5.0.cvs.20060524-1
kernel 2.6.17-rc6-mm2
Xorg 7.0.0
Acer TravelMate 3012, (--) Chipset 945GM found
and GL is extremely slow. The problem is verysimilar to bug #6672, but this time
on i910 driver. Starting googleearth gives me:
do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try running with LIBGL_THROTTLE_REFRESH and LIBL_SYNC_REFRESH unset.
and nothing is shown. 

Earlier I had dri/drm disabled and at this time googleearth was working
better/at all.

Any hints what I could try?

Best wishes

Norbert
Comment 1 Alan Hourihane 2006-06-15 00:12:03 UTC
Created attachment 5912 [details] [review]
Check Pipe B for IRQ's

Try applying this patch to your kernel sources in

/usr/src/linux/drivers/char/drm/i915_irq.c
Comment 2 Norbert Preining 2006-06-15 03:10:17 UTC
With this patch googleearth starts and works more or less as fast as in indirect
rendering.
So the one error is gone, the other that the rendering is quite slow is still
present. 

Do you know any other simple program (pref. in Debian/unstable) with which I can
test the performance? glxgears? But it does not give me any information (I
thought it says something about blabla fps before).

Thanks a lot and all the best

Norbert
Comment 3 Alan Hourihane 2006-06-15 03:14:00 UTC
I'm not sure what's in Debian. You could checkout the Mesa source from CVS and
use  the sample programs in progs/demos to test performance.

But if you are getting direct rendering, then it may just be that google earth
is hitting a slower path that may not be optimized or possibly even a software path.
Comment 4 Eric Preston 2006-07-31 00:50:16 UTC
This patch fixes the googleearth issue on my Dell D410 laptop with an i915GM.
The DFP on the laptop apparently is connected to PIPEB, normally.
It would be nice if it made upstream sometime soon.
Comment 5 Alan Hourihane 2006-08-18 01:50:47 UTC
It's in the relevant git repos now.

Closing.