Bug 7236 - "[drm:via_mem_alloc] *ERROR* Video memory allocation failed" after using Google Earth for some time
"[drm:via_mem_alloc] *ERROR* Video memory allocation failed" after using Goog...
Product: DRI
Classification: Unclassified
Component: DRM/other
XOrg git
x86 (IA32) Linux (All)
: high normal
Assigned To: Default DRI bug account
Depends on:
  Show dependency treegraph
Reported: 2006-06-15 06:32 UTC by Alexander Skwar
Modified: 2006-06-29 13:55 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Skwar 2006-06-15 06:32:34 UTC
I installed the new Google Earth Beta 4 for Linux on my Gentoo Linux system, and
after using GoogleEarth for some time, I get a lot of the following messages in
my debug syslog:

Jun 15 13:39:49 blatt [drm:via_mem_alloc] *ERROR* Video memory allocation failed

I'm using a

01:00.0 VGA compatible controller: VIA Technologies, Inc. S3 Unichrome Pro VGA
Adapter (rev 02)

on a notebook with a Celeron CPU.

What additional information should I supply?

alexander@blatt /var/log $ X -version

X Window System Version 7.1.0
Release Date: 22 May 2006
X Protocol Version 11, Revision 0, Release 7.1
Build Operating System: Linux 2.6.16-suspend2-r7.043.security-models i686
Current Operating System: Linux blatt 2.6.16-suspend2-r8.043.security-models #2
PREEMPT Fri Jun 9 21:09:15 CEST 2006 i686
Build Date: 09 June 2006
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Comment 1 Thomas Hellström 2006-06-15 07:59:46 UTC
I don't actually think this is a bug, but rather a leftover debug message in the
new memory manager code.

Can you verify that, apart from this message, everything seems normal and that
you have the following message:

[drm] Initialized via 2.10.0 20060528 on minor 0:

from the command
dmesg | grep drm

Comment 2 Alexander Skwar 2006-06-15 14:16:49 UTC
alexander@blatt ~/Desktop $ dmesg | grep drm
[drm] Initialized drm 1.0.1 20051102
[drm] Initialized via 2.10.0 20060528 on minor 0:
[drm:via_mem_alloc] *ERROR* Attempt to allocate from uninitialized memory manager.
[drm:via_mem_alloc] *ERROR* Video memory allocation failed
[drm:via_mem_alloc] *ERROR* Video memory allocation failed

But I *cannot* confirm, that everything seems normal. Since I started using
Google Earth, I experience lock ups (after using GE; when I don't use GE,
everything's fine). And since I started using GE, I see those video mem alloc
error messages.
Comment 3 Thomas Hellström 2006-06-27 22:50:10 UTC
The latest VIA DRM have the messages removed.

It seems like GE is not working well with a bunch of DRI drivers, so if it's not
a  GE bug, a new bug should probably be opened.

I'm closing this bug. If you have problems with other applications than GE,
please reopen.

Comment 4 Mario Emmenlauer 2006-06-29 13:44:47 UTC

I'm unable to use XvMC with xine using Gentoo's x11-drm-20060608,
on an VIA EPIA with CN400-Chipset. I get the same error message as Alexander:

[drm:via_mem_alloc] *ERROR* Video memory allocation failed

in dmesg, and xine is telling me:

ViaXvMC: Could not allocate timestamp blit area

I wouldn't have thought its drm's fault, but when using Gentoo's previous drm
(x11-drm-20051223), XvMC works fine and none of the error messages show up.

Comment 5 Thomas Hellström 2006-06-29 13:55:05 UTC

As mentioned previously this problem is fixed in latest DRM.
You need to wait for gentoo to upgrade or use CVS.