Bug 72976 - Brightness control becomes binary after suspend on haswell
Summary: Brightness control becomes binary after suspend on haswell
Status: RESOLVED DUPLICATE of bug 67454
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Chris Wilson
QA Contact: Intel GFX Bugs mailing list
Depends on:
Reported: 2013-12-22 19:44 UTC by Lionel Landwerlin
Modified: 2013-12-30 08:22 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Lionel Landwerlin 2013-12-22 19:44:56 UTC
I'm using Linux on my macbook air 2013 (haswell) (using Debian).
After a suspend cycle, the brightness will just go binary, full brightness for the 91-100%, and then completely blank under 91%.

I've noticed the behavior while using Gnome, then tried to reproduce 
by poking at /sys/devices/pci0000:00/0000:00:02.0/backlight/acpi_video0/brightness directly.

Then I tried poking at /sys/devices/pci0000:00/0000:00:02.0/drm/card0/card0-eDP-1/intel_backlight/brightness where the range is 0-2777. And I found the same kind of behavior, except that at the values 2303/2304, the screen would just keep going up/down in brightness without any interection on the /sys interface. Otherwise 2302 and below would be blank and 2305 and above would be full brightness 

It's using the following relevant components :

 xserver-xorg 7.7+4 
 xserver-xorg-video-intel 2.21.15-1+b2
 kernel 3.12.3

I guess the bug is more likely to be somewhere in the kernel than in the X driver.

Folks have reported the bug in other places already :


Comment 1 Jani Nikula 2013-12-30 08:22:35 UTC

*** This bug has been marked as a duplicate of bug 67454 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.