Bug 72980 - [IVB] Various GPU issues (glitches, etc.) since updating to Mint 16
Summary: [IVB] Various GPU issues (glitches, etc.) since updating to Mint 16
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-22 21:58 UTC by patrickthen
Modified: 2017-02-10 22:39 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Output from Xorg.0.log (25.80 KB, text/plain)
2013-12-22 21:58 UTC, patrickthen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description patrickthen 2013-12-22 21:58:53 UTC
Created attachment 91138 [details]
Output from Xorg.0.log

On my Lenovo Thinkpad Edge E330 (i3 3110M, HD4000), since upgrading to Mint 16, I got multiple issues with screen rendering:
* glitches/corruption mainly in Firefox and Thunderbird (random small black blocks in the browser window, of about 10x4 pixels, or corrupted text when scrolling)
* Various games that did run fine in Mint 15 using Wine/Playonlinux now give troubles: 
DeusEx refuses to use high-res textures form NewVision even when using OpenGL renderer and correct settings, Sword of the Stars: The Pit (I know, there's a native version, but I don't own that) refuses to start at all and complains that it could not find a Direct3D device that supports XNA framework reach profile - both of which worked fine under Mint 15.
Icewind Dale is unplayable fullscreen in OpenGL mode, since the picture flickers like crazy - windowed works fine.
I doubt that it's a Wine issue, since I made sure to use the same version and settings as before.
* Shadowrun Returns (native Linux version) produces glitches on overlays in the form of, for lack of better words, an array of small boxes/rectangles and lines that appears and quickly vanishes again, sometimes flickering on and off for a short time.

I installed the xorg-edgers ppa and updated, which seems to have affected the glitches in Firefox - I now don't get the small boxes on scrolling anymore, but rather the bottom right part of the screen is diagonally filled with an array of small coloured boxes for a fraction of a second, which just shows up and vanishes again randomly from time to time. 
Sorry that I can only offer this somewhat vague description, it happens too fast to capture it on a photo or screenshot...


As for my specs:
Mint 16 Cinnamon 64bit
Mesa version: 10.0.0-0ubuntu0sarvatt3 from edgers ppa
xserver-xorg-video-intel: 2:2.99.906+git20131213.f350a136-0ubuntu0sarvatt
Kernel: 3.11.0-12-generic x86_64 (64 bit)

Here's the output from inxi -Gxx:
Graphics:  
Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0 
X.Org: 1.14.4.901 drivers: intel (unloaded: fbdev,vesa) 
Resolution: 1366x768@60.0hz 
GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 10.0.0 Direct Rendering: Yes


Attached Xorg.0.log
Comment 1 patrickthen 2013-12-22 22:03:35 UTC
To specify - I did a fresh install of Mint 16, no distro upgrade.
Comment 2 Ian Romanick 2014-01-22 00:30:07 UTC
Are you using SNA for 2D acceleration?
Comment 3 patrickthen 2014-01-22 11:48:50 UTC
Yes - but I think I had tried setting it to UXA, without success.
To be sure, I'll try again tonight and report back!
Comment 4 patrickthen 2014-01-22 19:02:23 UTC
Ok, I tried to switch to UXA again, both by adding 

/etc/X11/xorg.conf.d/20-intel.conf

and by creating

/etc/X11/xorg.conf

and putting 

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection

into the respective files. Neither seems to have changed anything. Since I'm a noob with that stuff, is there a way to check whether I'm currently using SNA or UXA?
Comment 5 patrickthen 2014-01-22 19:33:48 UTC
Ok, forget that, I have checked /var/Xorg.0.log

with the "uxa" option, I find only uxa in the log, with "sna" only sna, so I guess I had switched to uxa.
Anyway, it did not change anything about my issues.

I have downgraded mesa and xserver again, since xorg-edgers had introduced another bug I couldn't get rid of otherwise.

New output from inxi -Gx:

Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0 
           X.Org: 1.14.5 driver: intel Resolution: 1366x768@60.0hz 
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile 
           GLX Version: 3.0 Mesa 9.2.1 Direct Rendering: Yes
Comment 6 Annie 2017-02-10 22:39:20 UTC
Dear Reporter,

This Mesa bug has been in the "NEEDINFO" status for over 60 days. I am closing this bug based on lack of response but feel free to reopen if resolution is still needed. Please ensure you're supplying the correct information as requested.

Thank you.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.