Bug 73225 - [SNB] gnome-shell rendering issues
Summary: [SNB] gnome-shell rendering issues
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 9.2
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-02 14:01 UTC by Stefan Nagy
Modified: 2014-05-16 07:46 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (46.36 KB, text/plain)
2014-01-02 14:01 UTC, Stefan Nagy
Details
dmesg output with boot option "drm.debug=0x06" (122.46 KB, text/plain)
2014-01-02 14:06 UTC, Stefan Nagy
Details
video showing rendering issues (1.43 MB, video/webm)
2014-01-02 14:07 UTC, Stefan Nagy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Nagy 2014-01-02 14:01:52 UTC
Created attachment 91419 [details]
Xorg.0.log

- Chipset: HM65
- System architecture: x86-64
- xf86-video-intel version: 2.21.15
- xserver version: 1.14.5
- mesa version: 9.2.2
- libdrm version: 2.4.50
- kernel version: 3.11-2-amd64
- linux distribution: Debian (testing)
- machine: HP Folio 13 - 2000
- display connector: HDMI

Most of the time (~70%) I get rendering issues in gnome-shell immediately after logging in (see attached video). It makes no difference if I have my external display connected or not. Normally logging out and back in (one or two times) solves the problem.

After logging in I change into gnome-shell activities view. If I see rendering issues I log out and in again until I get a normal view – then the problem is solved for the whole session (the problem won't occur after some time).
Comment 1 Stefan Nagy 2014-01-02 14:06:34 UTC
Created attachment 91420 [details]
dmesg output with boot option "drm.debug=0x06"
Comment 2 Stefan Nagy 2014-01-02 14:07:37 UTC
Created attachment 91421 [details]
video showing rendering issues
Comment 3 Stefan Nagy 2014-01-02 14:18:51 UTC
Sorry, I forgot to mention that this is a regression, I didn't have this problem in Debian stable. I'm not sure but as far as I remember I first encountered these rendering issues right after gnome 3.8 arrived in Debian testing.
Comment 4 Stefan Nagy 2014-04-15 07:24:24 UTC
The described visual artifacts seem to be caused by a bug in gnome-shell, see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=743810
Comment 5 Stefan Nagy 2014-05-16 07:46:55 UTC
Since this bug was confirmed on many different systems it seems proven to me that this is no hardware specific bug but a gnome-shell bug. So I'm closing this bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.